summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-02-17 11:26:51 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-02-17 16:16:35 +0200
commitf30382b42245a974c8e563b90da069c716f6b12d (patch)
treeb6e218c89baaa0ba85381f10318ef32b7eed14d9 /gnu/packages/ruby.scm
parent093beb65a584d6bb9826badbff672429d891da58 (diff)
downloadguix-patches-f30382b42245a974c8e563b90da069c716f6b12d.tar
guix-patches-f30382b42245a974c8e563b90da069c716f6b12d.tar.gz
gnu: Add ruby-oedipus-lex.
* gnu/packages/ruby.scm (ruby-oedipus-lex): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 90f885a379..e6992f3e21 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5519,6 +5519,29 @@ projects. It has very little overhead and can be easily integrated with
development tools to catch coverage problems early.")
(license license:expat)))
+(define-public ruby-oedipus-lex
+ (package
+ (name "ruby-oedipus-lex")
+ (version "2.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "oedipus_lex" version))
+ (sha256
+ (base32
+ "1v1rk78khwq87ar300lwll570zxpkq9rjnpgc9mgsyd6mm9qjz4w"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)))
+ (synopsis "Ruby lexer")
+ (description
+ "Oedipus Lex is a lexer generator in the same family as Rexical and Rex.
+It is based primarily on generating code much like you would a hand-written
+lexer. It uses StrScanner within a multi-level case statement. As such,
+Oedipus matches on the first match, not the longest.")
+ (home-page "https://github.com/seattlerb/oedipus_lex")
+ (license license:expat)))
+
(define-public ruby-guard
(package
(name "ruby-guard")