summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2021-01-04 02:00:12 +0100
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2021-02-28 23:16:22 +0100
commitd4baac70b85ec5f9690328c5e0b0adee84b6b420 (patch)
tree76bdc23321aae064f5fd859adbc35e2c6b431145 /gnu/packages/ruby.scm
parent8a7b4ce0936f456ebd57ea13ec64336d7cd51678 (diff)
downloadguix-patches-d4baac70b85ec5f9690328c5e0b0adee84b6b420.tar
guix-patches-d4baac70b85ec5f9690328c5e0b0adee84b6b420.tar.gz
gnu: Add ruby-jekyll-feed.
* gnu/packages/ruby.scm (ruby-jekyll-feed): New variable. Signed-off-by: Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8d3646847a..01f78fdb43 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12283,3 +12283,28 @@ exceptions with predefined messages.")
giving detailed reports on the time taken for each task.")
(home-page "https://github.com/ruby/benchmark")
(license license:bsd-2)))
+
+(define-public ruby-jekyll-feed
+ (package
+ (name "ruby-jekyll-feed")
+ (version "0.15.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jekyll-feed" version))
+ (sha256
+ (base32
+ "1zxqkrnix0xiw98531h5ga6h69jhzlx2jh9qhvcl67p8nq3sgza9"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #false)) ;there are none
+ (propagated-inputs
+ `(("jekyll" ,jekyll)))
+ (synopsis
+ "Jekyll plugin to generate an Atom feed of your Jekyll posts")
+ (description
+ "This package provides a Jekyll plugin to generate an Atom feed
+of your Jekyll posts.")
+ (home-page
+ "https://github.com/jekyll/jekyll-feed")
+ (license license:expat)))