summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-07-25 08:16:32 -0400
committerLudovic Courtès <ludo@gnu.org>2022-08-04 12:05:52 +0200
commitbc2de56572872eefdc2992b34cce69c77deb485a (patch)
treeb26dc710476e249c8c276360afe1e57e2e83a65e /gnu/packages/ruby.scm
parent3ee5460b6338246b0b1e97c77b3f4b676f8a92bc (diff)
downloadguix-patches-bc2de56572872eefdc2992b34cce69c77deb485a.tar
guix-patches-bc2de56572872eefdc2992b34cce69c77deb485a.tar.gz
gnu: ruby-anystyle-data: Don't write to installed gem.
* gnu/packages/patches/ruby-anystyle-data-immutable-install.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ruby.scm (ruby-anystyle-data)[patches]: Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index cdb9f53830..6e0b2dd14c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -13446,6 +13446,8 @@ the power of the built-in @code{OptionParser}.")
(snippet
;; remove pre-built file
#~(delete-file "lib/anystyle/data/dict.txt.gz"))
+ (patches
+ (search-patches "ruby-anystyle-data-immutable-install.patch"))
(file-name (git-file-name name version))))
(build-system ruby-build-system)
(arguments