summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-28 23:02:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-28 23:02:45 +0200
commitb09ef660c78f1b75e6da68b2d956864456fa832b (patch)
tree2524566f2efb9d5b7baba2e884b4abca97aad6b4 /gnu/packages/ruby.scm
parent7e309d0cb84c36844f94c4bd67c5dc9b8c6f9eb3 (diff)
downloadguix-patches-b09ef660c78f1b75e6da68b2d956864456fa832b.tar
guix-patches-b09ef660c78f1b75e6da68b2d956864456fa832b.tar.gz
gnu: ruby-oj: Don't use unstable tarball.
* gnu/packages/ruby.scm (ruby-oj)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 206f8e0527..482be70381 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4788,15 +4788,16 @@ unacceptable HTML and/or CSS from a string.")
(version "3.6.7")
(source
(origin
- (method url-fetch)
+ (method git-fetch)
;; Version on rubygems.org does not contain Rakefile, so download from
;; GitHub instead.
- (uri (string-append "https://github.com/ohler55/oj/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/ohler55/oj")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1x28ga72jxlnmsd8g8c0fw81vlh54r0qgagw2lxsd3x3la091g2h"))))
+ "1fqx58pwjiln7053lw2jy6ns4agcpxq2ac4f2fkd2ca3fxwpmh03"))))
(build-system ruby-build-system)
(arguments
'(#:test-target "test_all"
@@ -4815,7 +4816,7 @@ unacceptable HTML and/or CSS from a string.")
(description
"Oj is a JSON parser and generator for Ruby, where the encoding and
decoding of JSON is implemented as a C extension to Ruby.")
- (home-page "http://www.ohler.com/oj")
+ (home-page "http://www.ohler.com/oj/")
(license (list license:expat ; Ruby code
license:bsd-3)))) ; extension code