summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-18 12:58:23 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-18 13:00:07 +0200
commitac6914ca7d1c489fb295db784bd251a9e2426c7b (patch)
treecfd6fc36dacb1f07860dcb727ad88cb9212b7543 /gnu/packages/ruby.scm
parentb7a5641ad7dc610bc2042c22dce62d8b74764609 (diff)
downloadguix-patches-ac6914ca7d1c489fb295db784bd251a9e2426c7b.tar
guix-patches-ac6914ca7d1c489fb295db784bd251a9e2426c7b.tar.gz
gnu: Add ruby-cmath.
* gnu/packages/ruby.scm (ruby-cmath): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b07291b6de..7eee1df68d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12450,3 +12450,28 @@ resource assignment, cost and revenue planning, risk and communication
management, status tracking and reporting.")
(home-page "https://taskjuggler.org")
(license license:gpl2)))
+
+(define-public ruby-cmath
+ (package
+ (name "ruby-cmath")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "cmath" version))
+ (sha256
+ (base32
+ "1xkz6xyhpkjbdvpdib8450w62rls1mjryz0gzbbnadxkxn82nb8m"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #false))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis "Trigonometric functions for complex numbers")
+ (description
+ "This gem is a library that provides trigonometric and transcendental
+functions for complex numbers. The functions in this module accept integers,
+floating-point numbers or complex numbers as arguments.")
+ (home-page "https://github.com/ruby/cmath")
+ (license license:bsd-2)))