summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-27 10:17:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-10-27 10:17:14 +0100
commita557810ac72effd6841b76772195b10c03dee345 (patch)
tree26a4d7c1684d4c6fea155bfe05aa3b305499e36f /gnu/packages/ruby.scm
parent4c1918db34e09f0da793c607acc161bdf9ec5535 (diff)
parent2a19c0deb1da3a9afa8960367a5b84321386ceae (diff)
downloadguix-patches-a557810ac72effd6841b76772195b10c03dee345.tar
guix-patches-a557810ac72effd6841b76772195b10c03dee345.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 71d02eac52..b4fd02cd9a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Collin J. Doering <collin@rekahsoft.ca>
+;;; Copyright © 2019 Diego N. Barbato <dnbarbato@posteo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8966,3 +8967,29 @@ programming: intellisense, diagnostics, inline documentation, and type
checking.")
(home-page "https://solargraph.org/")
(license license:expat)))
+
+(define-public ruby-wayback-machine-downloader
+ (package
+ (name "ruby-wayback-machine-downloader")
+ (version "2.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri
+ "wayback_machine_downloader"
+ version))
+ (sha256
+ (base32
+ "12kb1qmvmmsaihqab1prn6cmynkn6cgb4vf41mgv22wkcgv5wgk2"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; no tests
+ (synopsis "Download archived websites from the Wayback Machine")
+ (description
+ "Wayback Machine Downloader is a command line tool for downloading
+websites from the Internet Archive's Wayback Machine (archive.org).
+It allows fine grained control over what to download by specifying
+which snapshots to consider and what files to include.")
+ (home-page
+ "https://github.com/hartator/wayback-machine-downloader")
+ (license license:expat)))