summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-20 10:33:12 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-20 23:51:24 +0200
commit955981534fecdc7eed133fffff198c7ce6347677 (patch)
treee803c3839ceca08bc38d7bda5c7c029aa008096a /gnu/packages/ruby.scm
parent72c785f95914c6a06bce4df5d180d129f06adae8 (diff)
downloadguix-patches-955981534fecdc7eed133fffff198c7ce6347677.tar
guix-patches-955981534fecdc7eed133fffff198c7ce6347677.tar.gz
gnu: Add ruby-hocon.
* gnu/packages/ruby.scm (ruby-hocon): New public variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index adc5753fb4..8f003f8000 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3560,6 +3560,38 @@ and manipulate Git repositories by wrapping system calls to the git binary.")
(home-page "https://github.com/schacon/ruby-git")
(license license:expat)))
+(define-public ruby-hocon
+ (package
+ (name "ruby-hocon")
+ (version "1.3.0")
+ (home-page "https://github.com/puppetlabs/ruby-hocon")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wz4cswjg3gs1y1bar7j4j88wjimfa9zhvy51jyi177i5dzax416"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "rspec")
+ (format #t "test suite not run~%"))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (synopsis "HOCON config library")
+ (description
+ "This package provides Ruby support for the @acronym{HOCON,
+Human-Optimized Config Object Notation} configuration file format. It
+supports parsing and modifying HOCON and JSON files, and rendering parsed
+objects back to a @code{String}.")
+ (license license:asl2.0)))
+
(define-public ruby-slop
(package
(name "ruby-slop")