summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-12 14:59:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-09-12 15:35:22 +0300
commit94676291fb383c9dc492bbfafdd787eddb473ff9 (patch)
tree80e649597f815fd80105416367bea018617f3e83 /gnu/packages/ruby.scm
parentcffc4124d4c4d4e6fbedf0ce931058d6612c2931 (diff)
downloadguix-patches-94676291fb383c9dc492bbfafdd787eddb473ff9.tar
guix-patches-94676291fb383c9dc492bbfafdd787eddb473ff9.tar.gz
gnu: ruby-rexml: Use version vendored with ruby.
* gnu/packages/ruby.scm (ruby-rubocop, ruby-crack) [propagated-inputs]: Remove ruby-rexml.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm3
1 files changed, 0 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b407d6d0e2..536cf15f99 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2099,8 +2099,6 @@ value is found.")
(invoke "ruby" "-Ilib" "-Itest" "-rrubygems" file))
(find-files "test" ".*rb$")))
#t)))))
- (propagated-inputs
- `(("ruby-rexml" ,ruby-rexml)))
(synopsis "Simple JSON and XML parsing for Ruby")
(description
"@code{crack} provides really simple JSON and XML parsing, extracted from
@@ -7376,7 +7374,6 @@ run.")
("ruby-parser" ,ruby-parser)
("ruby-rainbow" ,ruby-rainbow)
("ruby-regexp-parser" ,ruby-regexp-parser)
- ("ruby-rexml" ,ruby-rexml)
("ruby-rubocop-ast" ,ruby-rubocop-ast)
("ruby-progressbar" ,ruby-progressbar)
("ruby-unicode-display-width" ,ruby-unicode-display-width)))