summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-08 15:08:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-08 15:08:50 -0400
commit92ebbaad0924dcca8061604384452cd8e09965b3 (patch)
treee11886ee02ab756b008f57d68070c331a19cffa9 /gnu/packages/ruby.scm
parentf357462426584d5d6ffb0cc7ea60243577bf246c (diff)
downloadguix-patches-92ebbaad0924dcca8061604384452cd8e09965b3.tar
guix-patches-92ebbaad0924dcca8061604384452cd8e09965b3.tar.gz
gnu: ruby-cucumber: Update to 4.1.0.
* gnu/packages/ruby.scm (ruby-cucumber): Update to 4.1.0. [phases]{strip-version-requirements}: New phase. [propagated-inputs]: Add ruby-cucumber-create-meta, ruby-cucumber-html-formatter and ruby-cucumber-messages. Remove ruby-cucumber-expressions. [native-inputs]: Add ruby-rubocop. [description]: Reformat.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4eda0d17fe..a9b800acfd 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6648,7 +6648,7 @@ master/html-formatter/ruby")
(define-public ruby-cucumber
(package
(name "ruby-cucumber")
- (version "3.1.2")
+ (version "4.1.0")
(source
(origin
(method git-fetch)
@@ -6658,41 +6658,40 @@ master/html-formatter/ruby")
(file-name (git-file-name name version))
(sha256
(base32
- "0764wp2cjg60qa3l69q1dxda5g06a01n5w92szqbf89d2hgl47n3"))))
+ "0g9rqfslbzkkrq2kvl14fgknrhfbji3bjjpjxff5nc9wzd3hd549"))))
(build-system ruby-build-system)
(arguments
'(#:test-target "spec"
#:phases
(modify-phases %standard-phases
- ;; Don't run or require rubocop, the code linting tool, as this is a
- ;; bit unnecessary.
- (add-after 'unpack 'dont-run-rubocop
+ (add-after 'extract-gemspec 'strip-version-requirements
(lambda _
- (substitute* "Rakefile"
- ((".*rubocop/rake\\_task.*") "")
- ((".*RuboCop.*") ""))
+ (substitute* "cucumber.gemspec"
+ (("(.*add_.*dependency '[_A-Za-z0-9-]+').*" _ stripped)
+ (string-append stripped "\n")))
#t)))))
(propagated-inputs
`(("ruby-builder" ,ruby-builder)
("ruby-cucumber-core" ,ruby-cucumber-core)
+ ("ruby-cucumber-create-meta" ,ruby-cucumber-create-meta)
+ ("ruby-cucumber-html-formatter" ,ruby-cucumber-html-formatter)
+ ("ruby-cucumber-messages" ,ruby-cucumber-messages)
("ruby-cucumber-wire" ,ruby-cucumber-wire)
- ("ruby-cucumber-expressions" ,ruby-cucumber-expressions)
("ruby-diff-lcs" ,ruby-diff-lcs)
("ruby-gherkin" ,ruby-gherkin)
("ruby-multi-json" ,ruby-multi-json)
("ruby-multi-test" ,ruby-multi-test)))
(native-inputs
- `(("bundler" ,bundler)
- ;; Use a untested version of aruba, to avoid a circular dependency, as
+ `(;; Use a untested version of aruba, to avoid a circular dependency, as
;; ruby-aruba depends on ruby-cucumber.
("ruby-aruba", ruby-aruba-without-tests)
("ruby-rspec" ,ruby-rspec)
("ruby-pry" ,ruby-pry)
- ("ruby-nokogiri" ,ruby-nokogiri)))
+ ("ruby-nokogiri" ,ruby-nokogiri)
+ ("ruby-rubocop" ,ruby-rubocop)))
(synopsis "Describe automated tests in plain language")
- (description
- "Cucumber is a tool for running automated tests written in plain
-language. It's designed to support a Behaviour Driven Development (BDD)
+ (description "Cucumber is a tool for running automated tests written in
+plain language. It's designed to support a Behaviour Driven Development (BDD)
software development workflow.")
(home-page "https://cucumber.io/")
(license license:expat)))