summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-02-17 15:30:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-02-17 16:16:36 +0200
commit8588e6683c72d7c9c5e5a3a0573f4494ba22211c (patch)
tree7a38e65a2f5cc6fe4b3f86fc39a605ddb467766e /gnu/packages/ruby.scm
parentcc128eefd7ec77c84c5d8a5cab4db03823d13112 (diff)
downloadguix-patches-8588e6683c72d7c9c5e5a3a0573f4494ba22211c.tar
guix-patches-8588e6683c72d7c9c5e5a3a0573f4494ba22211c.tar.gz
gnu: Add ruby-rubocop-rspec.
* gnu/packages/ruby.scm (ruby-rubocop-rspec): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1934a68c01..bad97e8918 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1546,6 +1546,44 @@ logic.")
(home-page "https://github.com/typhoeus/typhoeus")
(license license:expat)))
+(define-public ruby-rubocop-rspec
+ (package
+ (name "ruby-rubocop-rspec")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rubocop-hq/rubocop-rspec")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gdpjpympb6qc77bang759z7z6lckf14ghkx8v6614agxg8l3g5y"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:test-target "internal_investigation"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-HOME
+ (lambda _
+ (setenv "HOME" "/tmp")
+ #t)))))
+ (propagated-inputs
+ `(("ruby-rubocop" ,ruby-rubocop)
+ ("ruby-rubocop-ast" ,ruby-rubocop-ast)))
+ (native-inputs
+ `(("ruby-rack" ,ruby-rack)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-rubocop-performance" ,ruby-rubocop-performance)
+ ("ruby-simplecov" ,ruby-simplecov)
+ ("ruby-yard" ,ruby-yard)))
+ (synopsis "Code style checking for RSpec files")
+ (description "This package provides a plugin for the RuboCop code style
+enforcing & linting tool.")
+ (home-page "https://github.com/rubocop-hq/rubocop-rspec")
+ (license license:expat)))
+
(define-public ruby-rubocop-performance
(package
(name "ruby-rubocop-performance")