summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-07-25 08:16:19 -0400
committerLudovic Courtès <ludo@gnu.org>2022-08-04 12:05:50 +0200
commit7ffea0822a25c54591b3cfeee0affd4d84afddca (patch)
tree172200ec9ee157129d2a531269cce3d91e0a6c2d /gnu/packages/ruby.scm
parent86c0bc5d482dd64acacb2ac361c92f831c66c0b1 (diff)
downloadguix-patches-7ffea0822a25c54591b3cfeee0affd4d84afddca.tar
guix-patches-7ffea0822a25c54591b3cfeee0affd4d84afddca.tar.gz
gnu: Add ruby-ritex.
* gnu/packages/ruby.scm (ruby-ritex): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2f47d898db..746bb9b6ce 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -13069,3 +13069,45 @@ based on the codebase of @url{https://wapiti.limsi.fr, Wapiti}.")
of various cultural backgrounds and tries to split them into their component
parts (e.g., given and family names, honorifics etc.).")
(license (list license:bsd-2 license:agpl3+))))
+
+(define-public ruby-ritex
+ (package
+ (name "ruby-ritex")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ritex" version))
+ (sha256
+ (base32
+ "07rlm3nyz9sxzy1srxs6a31hw81r6w7swrb85fiwi393z8npwc3a"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ (list itex2mml))
+ (arguments
+ ;; thanks to the Gentoo packagers for figuring this out
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'extract-gemspec 'fix-tests
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (substitute* "test/mathml.rb"
+ (("\\./itex2MML")
+ ;; don't use the absolute path to avoid keeping a reference
+ "itex2MML")
+ (("cmp ',\\\\,\\\\,,,\\\\,'" orig)
+ (string-append "# " orig " # patched for Guix")))
+ (substitute* "test/answer-key.yaml"
+ (("- ,\\\\,\\\\,,,\\\\," orig)
+ (string-append "# " orig " # patched for Guix")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ruby" "-Ilib:." "test/all.rb")))))))
+ (home-page "https://rubygems.org/gems/ritex")
+ (synopsis "Convert expressions from WebTeX into MathML")
+ (description
+ "Ritex converts expressions from WebTeX into MathML. WebTeX is an
+adaptation of TeX math syntax for web display. Ritex makes inserting math
+into HTML pages easy. It supports most TeX math syntax as well as macros.")
+ ;; doesn't clearly state -only vs -or-later
+ (license license:gpl2)))