summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-11 15:00:47 +0100
committerMarius Bakke <marius@gnu.org>2021-12-12 23:26:01 +0100
commit78bf278a802f3f3863880662b712fac05a00aed8 (patch)
tree05d2314ec9ce51b85b54fc4ee5dedaab7953f84f /gnu/packages/ruby.scm
parenta3b25dbfa6dc1923bad7adac2e226e8d49a2cdb5 (diff)
downloadguix-patches-78bf278a802f3f3863880662b712fac05a00aed8.tar
guix-patches-78bf278a802f3f3863880662b712fac05a00aed8.tar.gz
gnu: Add ruby-hoe-markdown.
* gnu/packages/ruby.scm (ruby-hoe-markdown): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7c9c7ebfd6..c6a1471eff 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9976,6 +9976,39 @@ generation.")
(home-page "https://github.com/jbarnette/hoe-git")
(license license:expat)))
+(define-public ruby-hoe-markdown
+ (package
+ (name "ruby-hoe-markdown")
+ (version "1.4.0")
+ (home-page "https://github.com/flavorjones/hoe-markdown")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wb0yjdx9gx9r0cahpx42pblvglgh1i9pdfxjavq7f40nan2g076"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:test-target "spec"
+ #:phases (modify-phases %standard-phases
+ (add-before 'check 'disable-bundler-dependency
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ (("require.*bundler/setup.*")
+ "")))))))
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)))
+ (propagated-inputs
+ `(("ruby-rake" ,ruby-rake)))
+ (synopsis "Hoe plugin with Markdown helpers")
+ (description
+ "This package provides a Hoe plugin with various Markdown helpers, which
+can be used to e.g. hyperlink Markdown documentation between project files.")
+ (license license:expat)))
+
(define-public ruby-sequel
(package
(name "ruby-sequel")