summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-28 22:53:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-28 22:55:07 +0200
commit3c6128f6f1b399b0cc9bc9364dcb9cbd3c68d1ee (patch)
tree421eced9e9e743a27700e4e1c4f663b19c5fc0ba /gnu/packages/ruby.scm
parent3d30c3321089c460d35f8bf09a435cc22a604477 (diff)
downloadguix-patches-3c6128f6f1b399b0cc9bc9364dcb9cbd3c68d1ee.tar
guix-patches-3c6128f6f1b399b0cc9bc9364dcb9cbd3c68d1ee.tar.gz
gnu: ruby-guard: Don't use unstable tarball.
* gnu/packages/ruby.scm (ruby-guard)[source]: Download using git-fetch. [home-page]: Use https.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c95123d432..206f8e0527 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3930,16 +3930,17 @@ invocation, and source and documentation browsing.")
(name "ruby-guard")
(version "2.13.0")
(source (origin
- (method url-fetch)
+ (method git-fetch)
;; The gem does not include a Rakefile, nor does it contain a
;; gemspec file, nor does it come with the tests. This is why
;; we fetch the tarball from Github.
- (uri (string-append "https://github.com/guard/guard/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/guard/guard")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1hwj0yi17k6f5axrm0k2bb7fq71dlp0zfywmd7pij9iimbppcca0"))))
+ "16pxcszr0g2jnl3090didxh1d8z5m2mly14m3w4rspb8fmclsnjs"))))
(build-system ruby-build-system)
(arguments
`(#:tests? #f ; tests require cucumber
@@ -3970,7 +3971,7 @@ invocation, and source and documentation browsing.")
"Guard is a command line tool to easily handle events on file system
modifications. Guard automates various tasks by running custom rules whenever
file or directories are modified.")
- (home-page "http://guardgem.org/")
+ (home-page "https://guardgem.org/")
(license license:expat)))
(define-public ruby-tilt