summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2019-08-12 21:20:01 +0200
committerJelle Licht <jlicht@fsfe.org>2019-08-15 20:42:10 +0200
commit369faa59955ffc2a81ac1a068c8b2c2fec7a4a12 (patch)
tree4e1c2f58ef552df5391886efd49bc66e0d600ee1 /gnu/packages/ruby.scm
parentd4cf5b018a6ec9170ca1b8c46023003c164364b9 (diff)
downloadguix-patches-369faa59955ffc2a81ac1a068c8b2c2fec7a4a12.tar
guix-patches-369faa59955ffc2a81ac1a068c8b2c2fec7a4a12.tar.gz
gnu: Add ruby-json-schema.
* gnu/packages/ruby.scm (ruby-json-schema): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1b70f842ae..94a5377c46 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Mikhail Kirillov <w96k.ru@gmail.com>
+;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8737,3 +8738,32 @@ then check out http://127.0.0.1:1080 to see the mail.")
"This package provides a pure Ruby library for event-driven IO.")
(home-page "https://github.com/castwide/backport")
(license license:expat)))
+
+(define-public ruby-json-schema
+ (package
+ (name "ruby-json-schema")
+ (version "2.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "json-schema" version))
+ (sha256
+ (base32
+ "1yv5lfmr2nzd14af498xqd5p89f3g080q8wk0klr3vxgypsikkb5"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (invoke "gem" "build" ".gemspec"))))))
+ (propagated-inputs
+ `(("ruby-addressable" ,ruby-addressable)))
+ (synopsis "Ruby JSON Schema Validator")
+ (description "This library provides Ruby with an interface for validating
+JSON objects against a JSON schema conforming to JSON Schema Draft 4. Legacy
+support for JSON Schema Draft 3, JSON Schema Draft 2, and JSON Schema Draft 1
+is also included.")
+ (home-page "https://github.com/ruby-json-schema/json-schema")
+ (license license:expat)))