summaryrefslogtreecommitdiff
path: root/gnu/packages/rsync.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-18 19:19:07 +0100
committerMarius Bakke <marius@gnu.org>2021-12-23 03:07:34 +0100
commitc0c9912b44deb216b2dec99a3dfd44909f1c50c4 (patch)
treeed1b1ca6d698bb47807cd8e71d0953ac831fccb8 /gnu/packages/rsync.scm
parenta89d65eec1948cbcbf9936939906fae9cdabf1e7 (diff)
downloadguix-patches-c0c9912b44deb216b2dec99a3dfd44909f1c50c4.tar
guix-patches-c0c9912b44deb216b2dec99a3dfd44909f1c50c4.tar.gz
gnu: rsync: Remove 3.1.3.
* gnu/packages/rsync.scm (rsync-next): Remove variable. (rsync): Update to 3.2.3. While at it, remove input labels.
Diffstat (limited to 'gnu/packages/rsync.scm')
-rw-r--r--gnu/packages/rsync.scm43
1 files changed, 6 insertions, 37 deletions
diff --git a/gnu/packages/rsync.scm b/gnu/packages/rsync.scm
index bce184da58..13717f0249 100644
--- a/gnu/packages/rsync.scm
+++ b/gnu/packages/rsync.scm
@@ -39,37 +39,6 @@
(define-public rsync
(package
(name "rsync")
- (version "3.1.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://rsync.samba.org/ftp/rsync/src/rsync-"
- version ".tar.gz"))
- (sha256
- (base32
- "1h0011dj6jgqpgribir4anljjv7bbrdcs8g91pbsmzf5zr75bk2m"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags
- ;; The bundled copies are preferred by default.
- (list "--without-included-zlib"
- "--without-included-popt")))
- (native-inputs
- (list perl))
- (inputs
- (list acl popt zlib))
- (synopsis "Remote (and local) file copying tool")
- (description
- "Rsync is a fast and versatile file copying tool. It can copy locally,
-to/from another host over any remote shell, or to/from a remote rsync daemon.
-Its delta-transfer algorithm reduces the amount of data sent over the network
-by sending only the differences between the source files and the existing
-files in the destination.")
- (license license:gpl3+)
- (home-page "https://rsync.samba.org/")))
-
-(define-public rsync-next
- (package
- (name "rsync")
(version "3.2.3")
(source (origin
(method url-fetch)
@@ -89,12 +58,12 @@ files in the destination.")
(native-inputs
(list perl))
(inputs
- `(("acl" ,acl)
- ("lz4" ,lz4)
- ("popt" ,popt)
- ("xxhash" ,xxhash)
- ("zlib" ,zlib)
- ("zstd:lib" ,zstd "lib")))
+ (list acl
+ lz4
+ popt
+ xxhash
+ zlib
+ `(,zstd "lib")))
(synopsis "Remote (and local) file copying tool")
(description
"Rsync is a fast and versatile file copying tool. It can copy locally,