summaryrefslogtreecommitdiff
path: root/gnu/packages/rsync.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-30 08:14:16 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-30 09:25:35 +0100
commitb598965866ed93a9ce0ee5b2cd9ac4ef7109ec9b (patch)
tree512d79842b5bf57a91627c243fcebeec3073e6c6 /gnu/packages/rsync.scm
parent865741166bb5af9bd641698cd6fd64fd1a7de8a7 (diff)
downloadguix-patches-b598965866ed93a9ce0ee5b2cd9ac4ef7109ec9b.tar
guix-patches-b598965866ed93a9ce0ee5b2cd9ac4ef7109ec9b.tar.gz
gnu: rsync: Update to 3.1.3.
* gnu/packages/rsync.scm (rsync): Update to 3.1.3. [source]: Remove patches for fixed CVEs. [properties]: Remove field. * packages/patches/rsync-CVE-2017-16548.patch: Delete file. * packages/patches/rsync-CVE-2017-17433.patch: Delete file. * packages/patches/rsync-CVE-2017-17433-fix-tests.patch: Delete file. * packages/patches/rsync-CVE-2017-17434-pt1.patch: Delete file. * packages/patches/rsync-CVE-2017-17434-pt2.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/rsync.scm')
-rw-r--r--gnu/packages/rsync.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/rsync.scm b/gnu/packages/rsync.scm
index d7fc188af2..4fed03523e 100644
--- a/gnu/packages/rsync.scm
+++ b/gnu/packages/rsync.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,22 +33,14 @@
(define-public rsync
(package
(name "rsync")
- (version "3.1.2")
+ (version "3.1.3")
(source (origin
(method url-fetch)
(uri (string-append "http://rsync.samba.org/ftp/rsync/src/rsync-"
version ".tar.gz"))
(sha256
(base32
- "1hm1q04hz15509f0p9bflw4d6jzfvpm1d36dxjwihk1wzakn5ypc"))
- (patches (search-patches "rsync-CVE-2017-16548.patch"
- "rsync-CVE-2017-17433.patch"
- "rsync-CVE-2017-17433-fix-tests.patch"
- "rsync-CVE-2017-17434-pt1.patch"
- "rsync-CVE-2017-17434-pt2.patch"
- ))
- ))
- (properties `((lint-hidden-cve . ("CVE-2017-15994")))) ; introduced after 3.1.2
+ "1h0011dj6jgqpgribir4anljjv7bbrdcs8g91pbsmzf5zr75bk2m"))))
(build-system gnu-build-system)
(inputs `(("perl" ,perl)
("acl" ,acl)))