summaryrefslogtreecommitdiff
path: root/gnu/packages/rsync.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/rsync.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/rsync.scm')
-rw-r--r--gnu/packages/rsync.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/rsync.scm b/gnu/packages/rsync.scm
index 956c942770..bce184da58 100644
--- a/gnu/packages/rsync.scm
+++ b/gnu/packages/rsync.scm
@@ -54,11 +54,9 @@
(list "--without-included-zlib"
"--without-included-popt")))
(native-inputs
- `(("perl" ,perl)))
+ (list perl))
(inputs
- `(("acl" ,acl)
- ("popt" ,popt)
- ("zlib" ,zlib)))
+ (list acl popt zlib))
(synopsis "Remote (and local) file copying tool")
(description
"Rsync is a fast and versatile file copying tool. It can copy locally,
@@ -89,7 +87,7 @@ files in the destination.")
;; Avoid these dependencies for now.
"--disable-openssl")))
(native-inputs
- `(("perl" ,perl)))
+ (list perl))
(inputs
`(("acl" ,acl)
("lz4" ,lz4)
@@ -122,10 +120,9 @@ files in the destination.")
"0bn29npmbw26akc6y54661irpdh6qcivcs6q48cgp3llklhhxp0q"))))
(build-system cmake-build-system)
(inputs
- `(("popt" ,popt)))
+ (list popt))
(native-inputs
- `(("which" ,which)
- ("perl" ,perl)))
+ (list which perl))
(home-page "http://librsync.sourceforge.net/")
(synopsis "Implementation of the rsync remote-delta algorithm")
(description