summaryrefslogtreecommitdiff
path: root/gnu/packages/rsync.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-05-20 08:20:27 -0500
committerEric Bavier <bavier@member.fsf.org>2014-05-25 23:33:58 -0500
commit7f0635f684b6646f266e1c890085e823b16f543d (patch)
treeb192facf88004c0b96487d4d813a50b7ced6d5cd /gnu/packages/rsync.scm
parentde0b620e88226cc9da6eaabf5a7c6111ba0fba3e (diff)
downloadguix-patches-7f0635f684b6646f266e1c890085e823b16f543d.tar
guix-patches-7f0635f684b6646f266e1c890085e823b16f543d.tar.gz
gnu: Add librsync.
* gnu/packages/rsync.scm (librsync): New variable.
Diffstat (limited to 'gnu/packages/rsync.scm')
-rw-r--r--gnu/packages/rsync.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/rsync.scm b/gnu/packages/rsync.scm
index c51d65c33e..a55febfdf4 100644
--- a/gnu/packages/rsync.scm
+++ b/gnu/packages/rsync.scm
@@ -20,6 +20,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages perl)
#:use-module (gnu packages acl)
+ #:use-module (gnu packages which)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
@@ -49,3 +50,29 @@ by sending only the differences between the source files and the existing
files in the destination.")
(license gpl3+)
(home-page "http://rsync.samba.org/")))
+
+(define-public librsync
+ (package
+ (name "librsync")
+ (version "0.9.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/projects/librsync/librsync/"
+ version "/librsync-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mj1pj99mgf1a59q9f2mxjli2fzxpnf55233pc1klxk2arhf8cv6"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("which" ,which)
+ ("perl" ,perl)))
+ (arguments '(#:configure-flags '("--enable-shared")))
+ (home-page "http://librsync.sourceforge.net/")
+ (synopsis "Implementation of the rsync remote-delta algorithm")
+ (description
+ "Librsync is a free software library that implements the rsync
+remote-delta algorithm. This algorithm allows efficient remote updates of a
+file, without requiring the old and new versions to both be present at the
+sending end. The library uses a \"streaming\" design similar to that of zlib
+with the aim of allowing it to be embedded into many different applications.")
+ (license lgpl2.1+)))