summaryrefslogtreecommitdiff
path: root/gnu/packages/rsync.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-13 11:00:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-13 12:49:21 +0200
commit6d29f6725d4d807e938e30cfb99802f9551f64d2 (patch)
tree360a0080eb7128e55f039d26e63c6802ca1a5475 /gnu/packages/rsync.scm
parentbbfb36f9bea797d72c0c2a415eccedd0881beb23 (diff)
downloadguix-patches-6d29f6725d4d807e938e30cfb99802f9551f64d2.tar
guix-patches-6d29f6725d4d807e938e30cfb99802f9551f64d2.tar.gz
gnu: librsync: Don't use unstable tarball.
* gnu/packages/rsync.scm (librsync)[source]: Use git-fetch and git-file-name.
Diffstat (limited to 'gnu/packages/rsync.scm')
-rw-r--r--gnu/packages/rsync.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/rsync.scm b/gnu/packages/rsync.scm
index b20b841478..39b295fdda 100644
--- a/gnu/packages/rsync.scm
+++ b/gnu/packages/rsync.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
;;;
@@ -30,6 +30,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu))
@@ -63,12 +64,14 @@ files in the destination.")
(name "librsync")
(version "2.0.2")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/librsync/librsync/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/librsync/librsync.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1waa581pcscc1rnvy06cj584k5dx0dc7jj79wsdj7xw4xqh9ayz6"))))
+ "1qnr4rk93mhggqjh2025clmlhhgnjhq983p1vbh8i1g8aiqdnapi"))))
(build-system cmake-build-system)
(inputs
`(("popt" ,popt)))