summaryrefslogtreecommitdiff
path: root/gnu/packages/rpc.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-06-02 16:25:37 -0500
committerLudovic Courtès <ludo@gnu.org>2020-06-09 10:43:54 +0200
commitfbc1cbb527b4c0e953d19fee537188c748621977 (patch)
treeffc63c455309d18e033ab72f86aa5671f9f4a4b1 /gnu/packages/rpc.scm
parentdacd126640bfcc5883b0ef618b8ac7a48c1f2d92 (diff)
downloadguix-patches-fbc1cbb527b4c0e953d19fee537188c748621977.tar
guix-patches-fbc1cbb527b4c0e953d19fee537188c748621977.tar.gz
gnu: Add apache-thrift.
* gnu/packages/rpc.scm (apache-thrift): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/rpc.scm')
-rw-r--r--gnu/packages/rpc.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/rpc.scm b/gnu/packages/rpc.scm
index 28c61b54f9..de7d08ae4d 100644
--- a/gnu/packages/rpc.scm
+++ b/gnu/packages/rpc.scm
@@ -25,10 +25,16 @@
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages adns)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
+ #:use-module (gnu packages flex)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
@@ -192,3 +198,46 @@ browsers to backend services.")
(description "This package provides a Python library for communicating
with the HTTP/2-based RPC framework gRPC.")
(license license:asl2.0)))
+
+(define-public apache-thrift
+ (package
+ (name "apache-thrift")
+ (version "0.13.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/apache/thrift.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17ckl7p7s3ga33yrjisilsimp80ansqxl54wvpkv0j7vx2zvc13y"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f
+ #:configure-flags
+ (list (string-append "--with-boost="
+ (assoc-ref %build-inputs "boost")))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("flex" ,flex)
+ ("bison" ,bison)))
+ (inputs
+ `(("boost" ,boost)
+ ("libressl" ,libressl)))
+ (outputs '("out" "lib" "include"))
+ (home-page "https://thrift.apache.org/")
+ (synopsis
+ "Lightweight, language-independent software stack for point-to-point
+RPC")
+ (description
+ "Thrift provides clean abstractions and implementations for data
+transport, data serialization, and application level processing. The code
+generation system takes a simple definition language as input and generates
+code across programming languages that uses the abstracted stack to build
+interoperable RPC clients and servers.")
+ (license license:asl2.0)))