summaryrefslogtreecommitdiff
path: root/gnu/packages/rpc.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-11-25 12:02:04 -0600
committerBrett Gilio <brettg@gnu.org>2020-11-25 12:02:04 -0600
commitf85490869e141567eb2a0909d0fc149605da5af9 (patch)
tree50239d643266c160f9e5400b0dc5df98cf5eb305 /gnu/packages/rpc.scm
parentef1bc776767aa7c095c7407e3092dbdaea4e1f80 (diff)
downloadguix-patches-f85490869e141567eb2a0909d0fc149605da5af9.tar
guix-patches-f85490869e141567eb2a0909d0fc149605da5af9.tar.gz
gnu: grpc: Update to 1.33.2.
* gnu/packages/rpc.scm (grpc): Update to 1.33.2. [arguments]: Use system (re2) provided package. [inputs]: Add re2. [native-inputs]: Add pkg-config.
Diffstat (limited to 'gnu/packages/rpc.scm')
-rw-r--r--gnu/packages/rpc.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/rpc.scm b/gnu/packages/rpc.scm
index e26170942b..cffa703fe0 100644
--- a/gnu/packages/rpc.scm
+++ b/gnu/packages/rpc.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,12 +39,13 @@
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages regex)
#:use-module (gnu packages tls))
(define-public grpc
(package
(name "grpc")
- (version "1.27.3")
+ (version "1.33.2")
(outputs '("out" "static"))
(source (origin
(method git-fetch)
@@ -53,7 +55,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0czmbwnafc7jnrrq2fnac2av83vs2q7q0wy4k11w9zbpld7j5h6d"))))
+ "09xd9pkyp10gh051kf8kwxn4myw42zv8kngr9z8wpm6mjy0j4ylw"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no test target
@@ -63,6 +65,7 @@
"-DgRPC_CARES_PROVIDER=package"
"-DgRPC_SSL_PROVIDER=package"
"-DgRPC_PROTOBUF_PROVIDER=package"
+ "-DgRPC_RE2_PROVIDER=package"
(string-append "-DCMAKE_INSTALL_PREFIX="
(assoc-ref %outputs "out"))
"-DCMAKE_INSTALL_LIBDIR=lib"
@@ -102,9 +105,11 @@
`(("abseil-cpp" ,abseil-cpp)
("c-ares" ,c-ares/cmake)
("openssl" ,openssl)
+ ("re2" ,re2)
("zlib" ,zlib)))
(native-inputs
- `(("protobuf" ,protobuf)
+ `(("pkg-config" ,pkg-config)
+ ("protobuf" ,protobuf)
("python" ,python-wrapper)))
(home-page "https://grpc.io")
(synopsis "High performance universal RPC framework")