summaryrefslogtreecommitdiff
path: root/gnu/packages/rpc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/rpc.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/rpc.scm')
-rw-r--r--gnu/packages/rpc.scm35
1 files changed, 13 insertions, 22 deletions
diff --git a/gnu/packages/rpc.scm b/gnu/packages/rpc.scm
index 0ff8363047..b4f4af9446 100644
--- a/gnu/packages/rpc.scm
+++ b/gnu/packages/rpc.scm
@@ -105,11 +105,7 @@
(find-files "." "\\.a$"))))
#t)))))
(inputs
- `(("abseil-cpp" ,abseil-cpp)
- ("c-ares" ,c-ares/cmake)
- ("openssl" ,openssl)
- ("re2" ,re2)
- ("zlib" ,zlib)))
+ (list abseil-cpp c-ares/cmake openssl re2 zlib))
(native-inputs
`(("pkg-config" ,pkg-config)
("protobuf" ,protobuf)
@@ -154,11 +150,9 @@ browsers to backend services.")
(("gettid\\(")
"sys_gettid("))))))))
(native-inputs
- `(("abseil-cpp" ,abseil-cpp-20200923.3)
- ("protobuf" ,protobuf-3.6)
- ,@(fold alist-delete (package-native-inputs grpc)
- '("abseil-cpp"
- "protobuf"))))))
+ (modify-inputs (package-native-inputs grpc)
+ (delete "abseil-cpp" "protobuf")
+ (prepend abseil-cpp-20200923.3 protobuf-3.6)))))
(define-public python-grpcio
(package
@@ -201,11 +195,9 @@ browsers to backend services.")
(("'cc'") "'gcc'"))
#t)))))
(inputs
- `(("c-ares" ,c-ares)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
+ (list c-ares openssl zlib))
(propagated-inputs
- `(("python-six" ,python-six)))
+ (list python-six))
(home-page "https://grpc.io")
(synopsis "HTTP/2-based RPC framework")
(description "This package provides a Python library for communicating
@@ -232,15 +224,14 @@ with the HTTP/2-based RPC framework gRPC.")
(list (string-append "--with-boost="
(assoc-ref %build-inputs "boost")))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("flex" ,flex)
- ("bison" ,bison)))
+ (list autoconf
+ automake
+ libtool
+ pkg-config
+ flex
+ bison))
(inputs
- `(("boost" ,boost)
- ("libressl" ,libressl)))
+ (list boost libressl))
(outputs '("out" "lib" "include"))
(home-page "https://thrift.apache.org/")
(synopsis