summaryrefslogtreecommitdiff
path: root/gnu/packages/rocm.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-08-05 15:33:47 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-08-08 16:47:52 +0200
commitdf90cb1d5c82cc83a305f6323f867f14e30ce240 (patch)
treedd7a020a0819970859c7fe7ca5ce9eb2f629acd6 /gnu/packages/rocm.scm
parenta75cc5f463eb5bfc003cbb4b22bbe86f80f01299 (diff)
downloadguix-patches-df90cb1d5c82cc83a305f6323f867f14e30ce240.tar
guix-patches-df90cb1d5c82cc83a305f6323f867f14e30ce240.tar.gz
gnu: Add rocm-cmake.
* gnu/packages/rocm.scm (%rocm-version, rocm-cmake): New variables.
Diffstat (limited to 'gnu/packages/rocm.scm')
-rw-r--r--gnu/packages/rocm.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/rocm.scm b/gnu/packages/rocm.scm
new file mode 100644
index 0000000000..b04eb8050e
--- /dev/null
+++ b/gnu/packages/rocm.scm
@@ -0,0 +1,57 @@
+;;;
+;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
+;;;
+;;; This program is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; This program is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages rocm)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix utils)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages elf)
+ #:use-module (gnu packages gl)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages llvm)
+ #:use-module (gnu packages opencl)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages vim))
+
+;; The components are tightly integrated and can only be upgraded as a unit. If
+;; you want to upgrade ROCm, bump this version number and update hashes below.
+(define %rocm-version "4.3.0")
+
+(define-public rocm-cmake
+ (package
+ (name "rocm-cmake")
+ (version %rocm-version)
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/RadeonOpenCompute/rocm-cmake.git")
+ (commit (string-append "rocm-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sic2zxmzl2pb2865vvq55mbpcr8pby8v19pjdlm08pypqw5h6h6"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; Tests try to use git commit
+ (native-inputs `(("git" ,git)))
+ (home-page "https://github.com/RadeonOpenCompute/rocm-cmake")
+ (synopsis "ROCm cmake modules")
+ (description "ROCm cmake modules provides cmake modules for common build
+tasks needed for the ROCM software stack.")
+ (license license:ncsa)))