summaryrefslogtreecommitdiff
path: root/gnu/packages/rocm.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-08-06 08:23:53 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-08-08 16:47:55 +0200
commitdc5755c41133bb303f775e2143a0919240f4562c (patch)
tree1f6562523e4f8047d1da584e85605c8bccf0b29f /gnu/packages/rocm.scm
parent9c083e706329909d41ab13d0721e726031ab78c7 (diff)
downloadguix-patches-dc5755c41133bb303f775e2143a0919240f4562c.tar
guix-patches-dc5755c41133bb303f775e2143a0919240f4562c.tar.gz
gnu: Add roct-thunk-interface.
* gnu/packages/rocm.scm (roct-thunk-interface): New variable.
Diffstat (limited to 'gnu/packages/rocm.scm')
-rw-r--r--gnu/packages/rocm.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/rocm.scm b/gnu/packages/rocm.scm
index 5ecc741d11..4ed4d95d60 100644
--- a/gnu/packages/rocm.scm
+++ b/gnu/packages/rocm.scm
@@ -147,3 +147,25 @@ oclc, ocml, ockl, opencl, hip and hc.")
(description "The Comgr library provides APIs for compiling and inspecting
AMDGPU code objects.")
(license license:ncsa)))
+
+(define-public roct-thunk-interface
+ (package
+ (name "roct-thunk-interface")
+ (version %rocm-version)
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface.git")
+ (commit (string-append "rocm-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ffqhrrscmcydfqf61dk58d7nnxk6n2k68jhqfj7a4hvhlphb74f"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; Not sure how to run tests.
+ (inputs `(("numactl" ,numactl)))
+ (home-page "https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface")
+ (synopsis "Radeon Open Compute Thunk Interface")
+ (description "User-mode API interfaces used to interact with the ROCk
+driver.")
+ (license license:ncsa)))