summaryrefslogtreecommitdiff
path: root/gnu/packages/rocm.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-08-10 23:43:10 +0200
committerLudovic Courtès <ludo@gnu.org>2021-08-11 16:35:28 +0200
commit9b54559e237b40ea56a604fa50b4dfa8a4437bc5 (patch)
tree41b330cddf9997a51417fc89b0a377840f62801a /gnu/packages/rocm.scm
parentd39b95b1c27ffc401bfdf6b624a421b81420a38b (diff)
downloadguix-patches-9b54559e237b40ea56a604fa50b4dfa8a4437bc5.tar
guix-patches-9b54559e237b40ea56a604fa50b4dfa8a4437bc5.tar.gz
gnu: rocm-opencl-runtime: Use a non-redirecting source URL.
* gnu/packages/rocm.scm (rocm-opencl-runtime)[source]: Use 'home-page' as the URL; since it lacks the ".git" prefix, that placates 'guix lint'.
Diffstat (limited to 'gnu/packages/rocm.scm')
-rw-r--r--gnu/packages/rocm.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/rocm.scm b/gnu/packages/rocm.scm
index fe85eaa642..8d6e3e69e2 100644
--- a/gnu/packages/rocm.scm
+++ b/gnu/packages/rocm.scm
@@ -258,10 +258,11 @@ allows runtimes to work on Windows as well as on Linux without much effort.")
(package
(name "rocm-opencl-runtime")
(version %rocm-version)
+ (home-page "https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime.git")
+ (url home-page)
(commit (string-append "rocm-" version))))
(file-name (git-file-name name version))
(sha256
@@ -299,7 +300,6 @@ allows runtimes to work on Windows as well as on Linux without much effort.")
("ocl-icd" ,ocl-icd)
("glew" ,glew)))
(native-inputs `())
- (home-page "https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime")
(synopsis "ROCm OpenCL Runtime")
(description "OpenCL 2.0 compatible language runtime, supporting offline
and in-process/in-memory compilation.")