summaryrefslogtreecommitdiff
path: root/gnu/packages/rocm.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-08-06 08:25:38 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-08-08 16:47:56 +0200
commit7221722dd53e466846ba6467373f7a71b28091e9 (patch)
tree2dd6bb06b7d8e92daec9be36416fc13e1d320758 /gnu/packages/rocm.scm
parenta85eff8171966ecba5b6c5bb66d7ff1f9fda7fb7 (diff)
downloadguix-patches-7221722dd53e466846ba6467373f7a71b28091e9.tar
guix-patches-7221722dd53e466846ba6467373f7a71b28091e9.tar.gz
gnu: Add rocclr.
* gnu/packages/rocm.scm (rocclr): New variable.
Diffstat (limited to 'gnu/packages/rocm.scm')
-rw-r--r--gnu/packages/rocm.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/rocm.scm b/gnu/packages/rocm.scm
index 2155ea2e49..631d8336c0 100644
--- a/gnu/packages/rocm.scm
+++ b/gnu/packages/rocm.scm
@@ -208,3 +208,48 @@ driver.")
(description "User-mode API interfaces and libraries necessary for host
applications to launch compute kernels to available HSA ROCm kernel agents.")
(license license:ncsa)))
+
+(define-public rocclr
+ (package
+ (name "rocclr")
+ (version %rocm-version)
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ROCm-Developer-Tools/ROCclr.git")
+ (commit (string-append "rocm-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pm1y020zriz7zmi95w0rcpka0jrsc7wwh81sssnysi8wxk3nnfy"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No tests.
+ #:configure-flags
+ `(,(string-append
+ "-DOPENCL_DIR="
+ (assoc-ref %build-inputs "rocm-opencl-runtime-src")))))
+ (inputs
+ `(("mesa" ,mesa)
+ ("rocm-comgr" ,rocm-comgr)
+ ("llvm" ,llvm-for-rocm)
+ ("rocm-device-libs" ,rocm-device-libs)
+ ("rocr-runtime" ,rocr-runtime)
+ ("rocm-cmake" ,rocm-cmake)
+ ;; rocclr depends on a few headers provided by rocm-opencl-runtime.
+ ("rocm-opencl-runtime-src"
+ ,(origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime.git")
+ (commit (string-append "rocm-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cglpiaj3ny1z74ssmy6j63vj92sfy4q38ix6qsga0mg3b2wvqz3"))))))
+ (home-page "https://github.com/ROCm-Developer-Tools/ROCclr")
+ (synopsis "Radeon Open Compute Common Language Runtime")
+ (description "ROCclr is a virtual device interface that compute runtimes
+interact with to different backends such as ROCr or PAL. This abstraction
+allows runtimes to work on Windows as well as on Linux without much effort.")
+ (license license:ncsa)))