summaryrefslogtreecommitdiff
path: root/gnu/packages/rocm.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-08-06 08:29:39 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-08-08 16:47:56 +0200
commit339762235d6eb323513aeff34149f3ab29b27227 (patch)
treef46897d5beeae861ceff2cfb1f2938835ba28890 /gnu/packages/rocm.scm
parent91ce17a53236578f8055a2588460047741983925 (diff)
downloadguix-patches-339762235d6eb323513aeff34149f3ab29b27227.tar
guix-patches-339762235d6eb323513aeff34149f3ab29b27227.tar.gz
gnu: Add rocm-bandwidth-test.
* gnu/packages/rocm.scm (rocm-bandwidth-test): New variable.
Diffstat (limited to 'gnu/packages/rocm.scm')
-rw-r--r--gnu/packages/rocm.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/rocm.scm b/gnu/packages/rocm.scm
index 0cf5a34b46..d6bd584146 100644
--- a/gnu/packages/rocm.scm
+++ b/gnu/packages/rocm.scm
@@ -325,3 +325,29 @@ and in-process/in-memory compilation.")
(synopsis "ROCm Application for Reporting System Info")
(description #f)
(license license:ncsa)))
+
+(define-public rocm-bandwidth-test
+ (package
+ (name "rocm-bandwidth-test")
+ (version %rocm-version)
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/RadeonOpenCompute/rocm_bandwidth_test.git")
+ (commit (string-append "rocm-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0a14kwkjpiyljgzxblh031qibn6xgbxp6m12zdy1pmwb2c44jjmm"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; No tests.
+ (inputs `(("rocr-runtime" ,rocr-runtime)))
+ (home-page "https://github.com/RadeonOpenCompute/rocm_bandwidth_test")
+ (synopsis "Bandwidth test for ROCm")
+ (description "RocBandwidthTest is designed to capture the performance
+characteristics of buffer copying and kernel read/write operations. The help
+screen of the benchmark shows various options one can use in initiating
+cop/read/writer operations. In addition one can also query the topology of the
+system in terms of memory pools and their agents.")
+ (license license:ncsa)))
+