summaryrefslogtreecommitdiff
path: root/gnu/packages/robotics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-09 21:53:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-14 00:24:42 -0400
commitea0a51071e68c37a4c9c25421cf03bc2f442c67b (patch)
treec30587b862169414a2170b86aae6ba4dbc5a2796 /gnu/packages/robotics.scm
parent0b5120fb03db5226871b3482a72b1e6fdaa59ead (diff)
downloadguix-patches-ea0a51071e68c37a4c9c25421cf03bc2f442c67b.tar
guix-patches-ea0a51071e68c37a4c9c25421cf03bc2f442c67b.tar.gz
gnu: Rename qtbase to qtbase-5.
This change was automated via the following command: $ git ls-files | xargs sed -i 's/,qtbase)/,qtbase-5)/g' $ git ls-files | xargs sed -i 's/inherit qtbase)/inherit qtbase-5)/g' $ git ls-files | xargs sed -i 's/package-version qtbase)/package-version qtbase-5)/g' $ git checkout etc # to clear some spurious changes This is done so the qtbase package can be upgraded to version 6 in the following commit.
Diffstat (limited to 'gnu/packages/robotics.scm')
-rw-r--r--gnu/packages/robotics.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/robotics.scm b/gnu/packages/robotics.scm
index fbf10be366..87dcc6f890 100644
--- a/gnu/packages/robotics.scm
+++ b/gnu/packages/robotics.scm
@@ -57,7 +57,7 @@
`(("sdl2" ,sdl2)))
(propagated-inputs
;; 'Viewer.h' includes 'QGLWidget'.
- `(("qtbase" ,qtbase) ;the viewer module needs Qt5 + MESA
+ `(("qtbase" ,qtbase-5) ;the viewer module needs Qt5 + MESA
("mesa" ,mesa)))
(synopsis "Robot simulator")
(description
@@ -107,7 +107,7 @@ hundred times faster than real-time.")
`(("dashel" ,dashel)
("enki" ,enki)
("protobuf" ,protobuf-3.5) ;for logging
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)
("qttools" ,qttools) ;for libQt5Help, needed by "studio"
("qtwebkit" ,qtwebkit)