summaryrefslogtreecommitdiff
path: root/gnu/packages/robotics.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/robotics.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/robotics.scm')
-rw-r--r--gnu/packages/robotics.scm35
1 files changed, 17 insertions, 18 deletions
diff --git a/gnu/packages/robotics.scm b/gnu/packages/robotics.scm
index 87dcc6f890..a110d0e6bd 100644
--- a/gnu/packages/robotics.scm
+++ b/gnu/packages/robotics.scm
@@ -51,14 +51,14 @@
(build-system cmake-build-system)
(arguments
'(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs (list pkg-config))
(inputs
;; Optionally, add Python + Boost for Python bindings.
- `(("sdl2" ,sdl2)))
+ (list sdl2))
(propagated-inputs
;; 'Viewer.h' includes 'QGLWidget'.
- `(("qtbase" ,qtbase-5) ;the viewer module needs Qt5 + MESA
- ("mesa" ,mesa)))
+ (list qtbase-5 ;the viewer module needs Qt5 + MESA
+ mesa))
(synopsis "Robot simulator")
(description
"Enki is a robot simulator written in C++. It provides collision and
@@ -101,21 +101,20 @@ hundred times faster than real-time.")
(arguments
'(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("valgrind" ,valgrind))) ;for tests
+ (list pkg-config valgrind)) ;for tests
(inputs
- `(("dashel" ,dashel)
- ("enki" ,enki)
- ("protobuf" ,protobuf-3.5) ;for logging
- ("qtbase" ,qtbase-5)
- ("qtsvg" ,qtsvg)
- ("qttools" ,qttools) ;for libQt5Help, needed by "studio"
- ("qtwebkit" ,qtwebkit)
- ("qtx11extras" ,qtx11extras)
- ("eudev" ,eudev)
- ("libxml2" ,libxml2)
- ("sdl2" ,sdl2)
- ("avahi" ,avahi))) ;XXX: we need the libdnssd compat layer
+ (list dashel
+ enki
+ protobuf-3.5 ;for logging
+ qtbase-5
+ qtsvg
+ qttools ;for libQt5Help, needed by "studio"
+ qtwebkit
+ qtx11extras
+ eudev
+ libxml2
+ sdl2
+ avahi)) ;XXX: we need the libdnssd compat layer
(synopsis "Event-based robot programming tools")
(description
"Aseba means @dfn{actuator and sensor event-based architecture}.