summaryrefslogtreecommitdiff
path: root/gnu/packages/regex.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-04-02 16:52:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-04-02 17:04:28 +0200
commite3bb89a9b78928f9b61d54649bfd5ac140833209 (patch)
treed661f3b12d9c5cb84ed185a60a77ca4dd1394dd5 /gnu/packages/regex.scm
parent1b362016bc60b4e4d6ad301024f895cb6fc788a4 (diff)
downloadguix-patches-e3bb89a9b78928f9b61d54649bfd5ac140833209.tar
guix-patches-e3bb89a9b78928f9b61d54649bfd5ac140833209.tar.gz
gnu: re2: Update to 2018-04-01.
* gnu/packages/regex.scm (re2): Update to 2018-04-01.
Diffstat (limited to 'gnu/packages/regex.scm')
-rw-r--r--gnu/packages/regex.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/regex.scm b/gnu/packages/regex.scm
index 1294149609..38a371d233 100644
--- a/gnu/packages/regex.scm
+++ b/gnu/packages/regex.scm
@@ -29,17 +29,15 @@
(define-public re2
(package
(name "re2")
- (version "2018-03-01")
+ (version "2018-04-01")
+ (home-page "https://github.com/google/re2")
(source (origin
(method url-fetch)
- (uri
- (string-append
- "https://github.com/google/re2/archive/"
- version ".tar.gz"))
+ (uri (string-append home-page "/archive/" version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0y21g321a802xmxdbkfz0rkcark7ypglpb3jjqhf13m6s7lpxp2i"))))
+ "04n9ngikvpikpshwcrl26sxgn8qbrymy3b5wlbsyfdhknx35951g"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -66,7 +64,6 @@
(delete-file (string-append (assoc-ref outputs "out")
"/lib/libre2.a"))
#t)))))
- (home-page "https://github.com/google/re2")
(synopsis "Fast, safe, thread-friendly regular expression engine")
(description "RE2 is a fast, safe, thread-friendly alternative to
backtracking regular expression engines like those used in PCRE, Perl and