summaryrefslogtreecommitdiff
path: root/gnu/packages/regex.scm
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@inbox.ru>2017-03-06 21:54:19 +0000
committerLudovic Courtès <ludo@gnu.org>2017-03-11 22:23:28 +0100
commit612af7ff66e0d5018bb696ff0140805bc8b5194e (patch)
tree07b8a8493c653fabf77dea36a29e6ad513e7f2af /gnu/packages/regex.scm
parente7b9dac7b1e31994860a3deeb70f0da43876e665 (diff)
downloadguix-patches-612af7ff66e0d5018bb696ff0140805bc8b5194e.tar
guix-patches-612af7ff66e0d5018bb696ff0140805bc8b5194e.tar.gz
gnu: re2: Set CXX for cross-compilation.
* gnu/packages/regex.scm (re2)[arguments]: Specify CXX in #:make-flags. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/regex.scm')
-rw-r--r--gnu/packages/regex.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/regex.scm b/gnu/packages/regex.scm
index 11f4716033..f55faaf042 100644
--- a/gnu/packages/regex.scm
+++ b/gnu/packages/regex.scm
@@ -22,7 +22,8 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (guix utils))
(define-public re2
(package
@@ -42,7 +43,16 @@
(arguments
`(#:test-target "test"
;; There is no configure step, but the Makefile respects a prefix.
- #:make-flags (list (string-append "prefix=" %output))
+ ;; As ./configure does not know anything about the target CXX
+ ;; we need to specify TARGET-g++ explicitly.
+ #:make-flags (list (string-append "prefix=" %output)
+ (string-append
+ "CXX=" ,(string-append
+ (if (%current-target-system)
+ (string-append
+ (%current-target-system) "-")
+ "")
+ "g++")))
#:phases
(modify-phases %standard-phases
(delete 'configure)