summaryrefslogtreecommitdiff
path: root/gnu/packages/readline.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-29 20:23:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-30 11:52:59 +0200
commit4562c60d984f135b7bdc45b92732f584862d6859 (patch)
tree3d5818f4b1621f79cb6df6d7777f993eec73019f /gnu/packages/readline.scm
parent8774e1b73709b24fa52b71293ec7f99b825e2af0 (diff)
downloadguix-patches-4562c60d984f135b7bdc45b92732f584862d6859.tar
guix-patches-4562c60d984f135b7bdc45b92732f584862d6859.tar.gz
gnu: rlwrap: Update to 0.45.1.
* gnu/packages/readline.scm (rlwrap): Update to 0.45.1. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add automake & autoconf.
Diffstat (limited to 'gnu/packages/readline.scm')
-rw-r--r--gnu/packages/readline.scm26
1 files changed, 15 insertions, 11 deletions
diff --git a/gnu/packages/readline.scm b/gnu/packages/readline.scm
index 8a36883347..3cca1aefe7 100644
--- a/gnu/packages/readline.scm
+++ b/gnu/packages/readline.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -23,10 +23,12 @@
(define-module (gnu packages readline)
#:use-module (guix licenses)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix utils)
#:use-module (ice-9 format))
@@ -144,19 +146,21 @@ comfortable for anyone.")
(define-public rlwrap
(package
(name "rlwrap")
- (version "0.43")
+ (version "0.45.1")
(source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/hanslub42/rlwrap/releases/"
- "download/v" version "/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "0bzb7ylk2770iv59v2d0gypb21y2xn87m299s9rqm6rdi2vx11lf"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hanslub42/rlwrap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0shf59mkql584a0p449psnbr26bfik5pizg4vsa75g4gbi6mn4r7"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("perl" ,perl)))
(inputs
`(("readline" ,readline)))
(synopsis "Wrapper to allow the editing of keyboard commands")