summaryrefslogtreecommitdiff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-14 22:24:50 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-14 22:24:50 +0100
commitee4722411fb71f90deb63e7976207f84ecae7360 (patch)
tree694419338693bfe06585650bb5baf3d296338bb0 /gnu/packages/rdf.scm
parent6145b604629c071fba8b55b7e0e3a45ed68fa3cc (diff)
downloadguix-patches-ee4722411fb71f90deb63e7976207f84ecae7360.tar
guix-patches-ee4722411fb71f90deb63e7976207f84ecae7360.tar.gz
gnu: python-rdflib: Disable tests.
* gnu/packages/rdf.scm (python-rdflib)[arguments]: Set #:tests? #f. [native-inputs]: Add python-nose. (python2-rdflib)[inputs]: Remove field. Use 'package-with-python2'.
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 1dd23c28e3..97e6b881cc 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -315,6 +315,18 @@ ideal (e.g. in LV2 implementations or embedded applications).")
(base32
"0kvaf332cqbi47rqzlpdx4mbkvw12mkrzkj8n9l19wk713d4py9w"))))
(build-system python-build-system)
+ (arguments
+ '(;; FIXME: Three test failures. Try uncommenting the below next update.
+ #:tests? #f))
+ ;; #:phases
+ ;; (modify-phases %standard-phases
+ ;; (replace 'check
+ ;; (lambda _
+ ;; ;; Run tests from the build directory so python3 only
+ ;; ;; sees the installed 2to3 version.
+ ;; (zero? (system* "nosetests" "--where=./build/src")))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
(propagated-inputs
`(("python-html5lib" ,python-html5lib)
("python-isodate" ,python-isodate)
@@ -329,12 +341,4 @@ powerful language for representing information.")
"See LICENSE in the distribution."))))
(define-public python2-rdflib
- (let ((base (package-with-python2 python-rdflib)))
- (package
- (inherit base)
- (inputs
- (append (package-inputs base)
- `(("python2-nose" ,python2-nose))))
- (arguments
- `(#:python ,python-2
- #:tests? #f))))) ; 3 tests fail, also outside Guix
+ (package-with-python2 python-rdflib))