summaryrefslogtreecommitdiff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-25 00:56:31 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-25 00:58:20 +0100
commitda71f145c6bf1aab4e5e9378609f4d5d6eae1093 (patch)
treebd6df9ac5aa2523b8265c46d8121a9fbc02a5ce0 /gnu/packages/rdf.scm
parent3dd7547666250c56c43ed216a9e8a0ae9a694107 (diff)
downloadguix-patches-da71f145c6bf1aab4e5e9378609f4d5d6eae1093.tar
guix-patches-da71f145c6bf1aab4e5e9378609f4d5d6eae1093.tar.gz
gnu: Add python2-rdflib.
* gnu/packages/rdf.scm (python2-rdflib): New variable. (python-rdflib): Add patch. * gnu/packages/patches/python2-rdflib-drop-sparqlwrapper.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch.
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 6895b36beb..ab6eb8940e 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -319,6 +319,9 @@ system.")
"https://pypi.python.org/packages/source/r/rdflib/rdflib-"
version
".tar.gz"))
+ (patches
+ ;; The patch has no effect under Python 3.
+ (list (search-patch "python2-rdflib-drop-sparqlwrapper.patch")))
(sha256
(base32
"0kvaf332cqbi47rqzlpdx4mbkvw12mkrzkj8n9l19wk713d4py9w"))))
@@ -336,3 +339,13 @@ system.")
powerful language for representing information.")
(license (bsd-style "file://LICENSE"
"See LICENSE in the distribution."))))
+
+(define-public python2-rdflib
+ (let ((base (package-with-python2 python-rdflib)))
+ (package
+ (inherit base)
+ (inputs
+ (append (package-inputs base)
+ `(("python2-nose" ,python2-nose))))
+ (arguments
+ `(#:tests? #f))))) ; 3 tests fail, also outside Guix