summaryrefslogtreecommitdiff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/rdf.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm70
1 files changed, 27 insertions, 43 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 4b7e6ce29e..83e5912464 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -71,10 +71,7 @@
"1vc02im4mpc28zxzgli68k6j0dakh0k3s389bm436yvqajxg19xd"))))
(build-system gnu-build-system)
(inputs
- `(("curl" ,curl)
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)
- ("zlib" ,zlib)))
+ (list curl libxml2 libxslt zlib))
(arguments
`(#:parallel-tests? #f))
(home-page "https://librdf.org/raptor/")
@@ -106,8 +103,8 @@ HTML and JSON.")
"clucene-contribs-lib.patch"))))
(build-system cmake-build-system)
(inputs
- `(("boost" ,boost) ; could also use bundled copy
- ("zlib" ,zlib)))
+ (list boost ; could also use bundled copy
+ zlib))
(arguments
`(#:test-target "cl_test"
#:configure-flags '("-DBUILD_CONTRIBS_LIB=ON")
@@ -146,9 +143,9 @@ Java Lucene text search engine API to C++.")
;; Install in lib64 break rpath
"-DCMAKE_INSTALL_LIBDIR:PATH=lib")))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("boost" ,boost)))
+ (list boost))
(home-page "https://github.com/luceneplusplus/LucenePlusPlus")
(synopsis "Text search engine")
(description "Lucene++ is an up to date C++ port of the popular Java
@@ -187,10 +184,7 @@ Lucene library, a high-performance, full-featured text search engine.")
("cyrus-sasl" ,cyrus-sasl)
("zlib" ,zlib)))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list autoconf automake libtool pkg-config))
(home-page "https://github.com/swh/LRDF")
(synopsis "Lightweight RDF library for accessing LADSPA plugin metadata")
(description
@@ -213,17 +207,13 @@ taxonomic inference capability.")
"0z6rrwn4jsagvarg8d5zf0j352kjgi33py39jqd29gbhcnncj939"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl)
- ("perl-xml-dom" ,perl-xml-dom) ; for the tests
- ("pkg-config" ,pkg-config)))
+ (list perl perl-xml-dom ; for the tests
+ pkg-config))
(inputs
- `(("libgcrypt" ,libgcrypt)
- ("libxml2" ,libxml2)
- ("mpfr" ,mpfr)
- ("pcre" ,pcre)
- ("util-linux" ,util-linux "lib")))
+ (list libgcrypt libxml2 mpfr pcre
+ `(,util-linux "lib")))
(propagated-inputs
- `(("raptor2" ,raptor2))) ; stipulated by rasqal.pc
+ (list raptor2)) ; stipulated by rasqal.pc
(arguments
`(#:parallel-tests? #f
; test failure reported upstream, see
@@ -254,12 +244,12 @@ Turtle/N3 and read them in SPARQL XML, RDF/XML and Turtle/N3.")
"109n0kp39p966dpiasad2bb7q66rwbcb9avjvimw28chnpvlf66y"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl) ; needed for installation
- ("pkg-config" ,pkg-config)))
+ (list perl ; needed for installation
+ pkg-config))
(propagated-inputs
- `(("rasqal" ,rasqal))) ; in Requires.private field of .pc
+ (list rasqal)) ; in Requires.private field of .pc
(inputs
- `(("bdb" ,bdb)))
+ (list bdb))
(home-page "http://librdf.org/")
(synopsis "RDF library")
(description "The Redland RDF Library (librdf) provides the RDF API
@@ -324,11 +314,11 @@ ideal (e.g. in LV2 implementations or embedded applications).")
(assoc-ref outputs "out") "/lib"))
#t)))))
(inputs
- `(("pcre" ,pcre)))
+ (list pcre))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(propagated-inputs
- `(("serd" ,serd))) ; required by sord-0.pc
+ (list serd)) ; required by sord-0.pc
(home-page "https://drobilla.net/software/sord/")
(synopsis "C library for storing RDF data in memory")
(description
@@ -358,11 +348,9 @@ ideal (e.g. in LV2 implementations or embedded applications).")
;; ;; sees the installed 2to3 version.
;; (invoke "nosetests" "--where=./build/src"))))))
(native-inputs
- `(("python-nose" ,python-nose)))
+ (list python-nose))
(propagated-inputs
- `(("python-html5lib" ,python-html5lib)
- ("python-isodate" ,python-isodate)
- ("python-pyparsing" ,python-pyparsing)))
+ (list python-html5lib python-isodate python-pyparsing))
(home-page "https://github.com/RDFLib/rdflib")
(synopsis "Python RDF library")
(description
@@ -387,9 +375,9 @@ powerful language for representing information.")
"1v85f4hdlrrk0l1najmqmm79ijrvcj259kwsrrxiq1q5chr5azag"))))
(build-system python-build-system)
(native-inputs
- `(("python-nose" ,python-nose)))
+ (list python-nose))
(propagated-inputs
- `(("python-rdflib" ,python-rdflib)))
+ (list python-rdflib))
(home-page "https://github.com/RDFLib/rdflib-jsonld")
(synopsis "rdflib extension adding JSON-LD parser and serializer")
(description "This package provides an rdflib extension adding JSON-LD
@@ -409,7 +397,7 @@ parser and serializer.")
"0x7yz0lvqb6mkhl5fbml27sppmscgpf8v2ism9jzzf0h982ffzxm"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-rdflib" ,python-rdflib)))
+ (list python-rdflib))
(home-page "https://github.com/hsolbrig/CFGraph")
(synopsis "RDF Collections flattener for rdflib")
(description
@@ -431,13 +419,9 @@ parser and serializer.")
"1vsq80jnix6cy78ayag7v8ajyw7h8dqyad1q6xkf2hzz3skvr34z"))))
(build-system gnu-build-system)
(inputs
- `(("serd" ,serd)
- ("zlib" ,zlib)))
+ (list serd zlib))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list autoconf automake libtool pkg-config))
(home-page "https://github.com/rdfhdt/hdt-cpp")
(synopsis "C++ implementation of the HDT compression format")
(description "Header Dictionary Triples (HDT) is a compression format for
@@ -462,9 +446,9 @@ C++ library as well as various command-line tools to to work with HDT.")
(arguments
'(#:tests? #f)) ; The test suite simply queries external HTTP endpoints.
(native-inputs
- `(("python-nose" ,python-nose)))
+ (list python-nose))
(propagated-inputs
- `(("python-rdflib" ,python-rdflib)))
+ (list python-rdflib))
(home-page "https://rdflib.dev/sparqlwrapper/")
(synopsis "SPARQL Endpoint interface to Python")
(description "Python wrapper around a SPARQL service. It helps in creating