summaryrefslogtreecommitdiff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-07-21 13:31:08 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-07-21 13:36:09 +0200
commit281808170a2a5182f174d795232b80c1aaf30caf (patch)
treed688404a1306f265cc74639f31c01f644417a2bf /gnu/packages/rdf.scm
parentd57c34d26b8b5a7d17a5b8811742c5f291567209 (diff)
downloadguix-patches-281808170a2a5182f174d795232b80c1aaf30caf.tar
guix-patches-281808170a2a5182f174d795232b80c1aaf30caf.tar.gz
gnu: Add python-sparqlwrapper.
* gnu/packages/rdf.scm (python-sparqlwrapper): New variable.
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 0baed8fc17..fb84d8053d 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -443,3 +443,30 @@ parser and serializer.")
RDF data that can also be queried for Triple Patterns. This package provides a
C++ library as well as various command-line tools to to work with HDT.")
(license license:lgpl2.1+)))
+
+(define-public python-sparqlwrapper
+ (package
+ (name "python-sparqlwrapper")
+ (version "1.8.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/RDFLib/sparqlwrapper.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ia5h06zf6kpw6gdi7f80pzx10m79brj08zrbffb5wn9hzz8x528"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; The test suite simply queries external HTTP endpoints.
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-rdflib" ,python-rdflib)))
+ (home-page "https://rdflib.dev/sparqlwrapper/")
+ (synopsis "SPARQL Endpoint interface to Python")
+ (description "Python wrapper around a SPARQL service. It helps in creating
+the query URI and, possibly, convert the result into a more manageable
+format.")
+ (license license:w3c)))