summaryrefslogtreecommitdiff
path: root/gnu/packages/rdesktop.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-07-20 09:58:42 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-25 02:00:22 -0400
commitdd3de0c475c37565a8e1a219c1b7a8aff1c7ff5d (patch)
tree4b9aded45438a4a5ac01fefbb7e0294f13df6564 /gnu/packages/rdesktop.scm
parente0fc0913195a9e79dafc6075764132126fbd7d9c (diff)
downloadguix-patches-dd3de0c475c37565a8e1a219c1b7a8aff1c7ff5d.tar
guix-patches-dd3de0c475c37565a8e1a219c1b7a8aff1c7ff5d.tar.gz
gnu: freerdp: Propagate some inputs as per pkg-config files.
* gnu/packages/rdesktop.scm (freerdp)[inputs]: Move libxkbcommon, openssl and wayland to ... [propagated-inputs]: ... here.
Diffstat (limited to 'gnu/packages/rdesktop.scm')
-rw-r--r--gnu/packages/rdesktop.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/rdesktop.scm b/gnu/packages/rdesktop.scm
index 30523deefe..adfbe7de06 100644
--- a/gnu/packages/rdesktop.scm
+++ b/gnu/packages/rdesktop.scm
@@ -108,7 +108,6 @@ to remotely control a user's Windows desktop.")
("libjpeg" ,libjpeg-turbo)
("libusb" ,libusb)
("libx11" ,libx11)
- ("libxkbcommon" ,libxkbcommon)
("libxkbfile" ,libxkbfile)
("libxcursor" ,libxcursor)
("libxext" ,libxext)
@@ -118,10 +117,12 @@ to remotely control a user's Windows desktop.")
("libxrender" ,libxrender)
("libxinerama" ,libxinerama)
("libxshmfence" ,libxshmfence)
- ("openssl" ,openssl)
("pulseaudio" ,pulseaudio)
- ("wayland" ,wayland)
("zlib" ,zlib)))
+ (propagated-inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("openssl" ,openssl)
+ ("wayland" ,wayland)))
(arguments
`(#:build-type "RELEASE"
#:configure-flags