summaryrefslogtreecommitdiff
path: root/gnu/packages/rcm.scm
diff options
context:
space:
mode:
authorJosh Holland <josh@inv.alid.pw>2019-05-09 18:59:16 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-15 23:48:33 +0100
commit305c908aac9ed3ec1be9361cb998d6a25c15fded (patch)
tree69c14fda86f74eda4583b67b0d5a86ef3b40c5fd /gnu/packages/rcm.scm
parent04b201bb0feacd2997a66b73a574160f0b32697b (diff)
downloadguix-patches-305c908aac9ed3ec1be9361cb998d6a25c15fded.tar
guix-patches-305c908aac9ed3ec1be9361cb998d6a25c15fded.tar.gz
gnu: Add rcm.
* gnu/packages/rcm.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add rcm.scm. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/rcm.scm')
-rw-r--r--gnu/packages/rcm.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/rcm.scm b/gnu/packages/rcm.scm
new file mode 100644
index 0000000000..c61626d114
--- /dev/null
+++ b/gnu/packages/rcm.scm
@@ -0,0 +1,62 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages rcm)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages perl))
+
+(define-public rcm
+ (package
+ (name "rcm")
+ (version "1.3.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://thoughtbot.github.io/rcm/dist/rcm-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1bqk7rrp1ckzvsvl9wghsr77m8xl3a7yc5gqdsisz492dx2j8mck"))))
+ (build-system gnu-build-system)
+ (arguments '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-source-shebangs 'patch-tests
+ (lambda _
+ (substitute* '("test/rcrc-tilde.t"
+ "test/rcdn-hooks-run-in-order.t"
+ "test/rcup-hooks-run-in-order.t")
+ (("/bin/sh") (which "sh")))
+ (substitute* "test/rcup-hooks.t"
+ (("/usr/bin/env") (which "env")))
+ #t)))
+ #:parallel-tests? #f))
+ (native-inputs `(("perl" ,perl)
+ ("python-cram" ,python-cram)))
+ (synopsis "Management suite for dotfiles")
+ (description "The rcm suite of tools is for managing dotfiles directories. This is
+a directory containing all the @code{.*rc} files in your home directory
+(@code{.zshrc}, @code{.vimrc}, and so on). These files have gone by many
+names in history, such as “rc files” because they typically end in rc
+or “dotfiles” because they begin with a period. This suite is useful
+for committing your rc files to a central repository to share, but it also
+scales to a more complex situation such as multiple source directories
+shared between computers with some host-specific or task-specific files.")
+ (license bsd-3)
+ (home-page "https://github.com/thoughtbot/rcm")))