summaryrefslogtreecommitdiff
path: root/gnu/packages/raspberry-pi.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-10-29 15:25:40 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-10-29 15:25:40 +0100
commit7abe768ec12b9a195d4b24167dc7989391959b22 (patch)
tree49841fdf803ec8a2dba44140ae532ceb3fe61fdf /gnu/packages/raspberry-pi.scm
parent2ea99f4e84eeb166daea082bb9b1cf179d68efee (diff)
downloadguix-patches-7abe768ec12b9a195d4b24167dc7989391959b22.tar
guix-patches-7abe768ec12b9a195d4b24167dc7989391959b22.tar.gz
gnu: raspi-arm64-chainloader: Install arm64.bin.
* gnu/packages/raspberry-pi.scm (raspi-arm64-chainloader)[arguments]<#:phases>[setenv]: Add objcopy. [install]: Install arm64.bin.
Diffstat (limited to 'gnu/packages/raspberry-pi.scm')
-rw-r--r--gnu/packages/raspberry-pi.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/raspberry-pi.scm b/gnu/packages/raspberry-pi.scm
index 78871f795e..0e58d3b780 100644
--- a/gnu/packages/raspberry-pi.scm
+++ b/gnu/packages/raspberry-pi.scm
@@ -190,6 +190,7 @@ Raspberry Pi. Note: It does not work on Raspberry Pi 1.")
(replace 'setenv
(lambda _
(setenv "AS" "as") ; TODO: as-for-target
+ (setenv "OBJCOPY" "objcopy")
(setenv "CC" ,(cc-for-target))
(setenv "CXX" ,(cc-for-target))
(setenv "BAREMETAL" "1")
@@ -229,5 +230,6 @@ Raspberry Pi. Note: It does not work on Raspberry Pi 1.")
(libexec (string-append out "/libexec")))
(mkdir-p libexec)
(install-file "arm64.elf" libexec)
- (install-file "arm64.map" libexec)))))))))
+ (install-file "arm64.map" libexec)
+ (install-file "arm64.bin" libexec)))))))))
(supported-systems '("aarch64-linux"))))