summaryrefslogtreecommitdiff
path: root/gnu/packages/raspberry-pi.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-10-29 09:59:34 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-10-29 12:39:57 +0100
commit22c487677a7c25cdb7df01cd0cc3453e21250e30 (patch)
tree2aad82de9069027ac8977e6f1813b0e4b7983889 /gnu/packages/raspberry-pi.scm
parentc298c8896c6eaeb842e406cce7ec0489c868390b (diff)
downloadguix-patches-22c487677a7c25cdb7df01cd0cc3453e21250e30.tar
guix-patches-22c487677a7c25cdb7df01cd0cc3453e21250e30.tar.gz
gnu: Add raspi-gpio.
* gnu/packages/raspberry-pi.scm (raspi-gpio): New variable.
Diffstat (limited to 'gnu/packages/raspberry-pi.scm')
-rw-r--r--gnu/packages/raspberry-pi.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/raspberry-pi.scm b/gnu/packages/raspberry-pi.scm
index 60bddf6536..89291d6c13 100644
--- a/gnu/packages/raspberry-pi.scm
+++ b/gnu/packages/raspberry-pi.scm
@@ -62,3 +62,28 @@ used in the Raspberry Pi")
(supported-systems '("armhf-linux" "aarch64-linux"))
(license license:gpl3)))
+(define raspi-gpio
+ (let ((commit "6d0769ac04760b6e9f33b4aa1f11c682237bf368")
+ (revision "1"))
+ (package
+ (name "raspi-gpio")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/RPi-Distro/raspi-gpio.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fia1ma586hwhpda0jz86j6i55andq0wncbhzhzvhf7yc773cpi4"))))
+ (build-system gnu-build-system)
+ (synopsis "State dumper for BCM270x GPIOs")
+ (description "Tool to help debug / hack at the BCM283x GPIO. You can dump
+ the state of a GPIO or (all GPIOs). You can change a GPIO mode and pulls (and
+ level if set as an output). Beware this tool writes directly to the BCM283x
+ GPIO reisters, ignoring anything else that may be using them (like Linux
+ drivers).")
+ (home-page "https://github.com/RPi-Distro/raspi-gpio")
+ (supported-systems '("armhf-linux" "aarch64-linux"))
+ (license license:bsd-3))))