summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/radio.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm81
1 files changed, 81 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index e9e8e08aa5..2b578d62b5 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -52,6 +52,7 @@
#:use-module (gnu packages geo)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages golang)
@@ -535,6 +536,7 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
("python-pyqt" ,python-pyqt-without-qtwebkit)
+ ("python-pyqtgraph" ,python-pyqtgraph)
("python-pyyaml" ,python-pyyaml)
("qtbase" ,qtbase-5)
("qwt" ,qwt)
@@ -2105,6 +2107,54 @@ voice formats.")
various hardware.")
(license license:gpl3+)))
+(define-public sdr++
+ (package
+ (name "sdr++")
+ (version "1.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AlexandreRouma/SDRPlusPlus")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mplhys07l4bqv3q301ayh35468mg0hpxp5zgrps7gkjyf3v6idr"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("gcc" ,gcc-10) ; A GCC more recent than version 7 is required.
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("airspyhf" ,airspyhf)
+ ("alsa-lib" ,alsa-lib)
+ ("fftwf" ,fftwf)
+ ("glew" ,glew)
+ ("glfw" ,glfw)
+ ("hackrf" ,hackrf)
+ ("jack" ,jack-2)
+ ("libusb" ,libusb)
+ ("pulseaudio" ,pulseaudio)
+ ("rtaudio" ,rtaudio)
+ ("rtl-sdr" ,rtl-sdr)
+ ("soapysdr" ,soapysdr)
+ ("volk" ,volk)))
+ (arguments
+ `(#:tests? #f ; No test suite.
+ #:configure-flags '("-DOPT_BUILD_AIRSPY_SOURCE=OFF"
+ "-DOPT_BUILD_PLUTOSDR_SOURCE=OFF")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("/usr")
+ (assoc-ref outputs "out"))))))))
+ (home-page "https://github.com/AlexandreRouma/SDRPlusPlus")
+ (synopsis "Software defined radio software")
+ (description
+ "SDR++ is a software defined radio software for various hardware.")
+ (license license:gpl3+)))
+
(define-public inspectrum
(package
(name "inspectrum")
@@ -2283,6 +2333,37 @@ this package. E.g.: @code{(udev-rules-service 'rfcat rfcat)}")
(license (list license:bsd-3
license:gpl2)))))
+(define-public rx-tools
+ ;; No tagged release since 2016, use commit instead.
+ (let ((commit "811b21c4c8a592515279bd19f7460c6e4ff0551c")
+ (revision "1"))
+ (package
+ (name "rx-tools")
+ (version (git-version "1.0.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rxseger/rx_tools")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qr8q00cv6q0ikjrph0qh07mlbvgk4yimccpkn3ir8ib5ma0r9sr"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("soapysdr" ,soapysdr)))
+ (arguments
+ `(#:tests? #f)) ; No test suite.
+ (home-page "https://github.com/rxseger/rx_tools")
+ (synopsis "Command line programs for receiving data from SDRs")
+ (description
+ "This package provides the @code{rx_fm}, @code{rx_power} and
+@code{rx_sdr} tools for receiving data from SDRs, based on @code{rtl_fm},
+@code{rtl_power} and @code{rtl_sdr} from RTL-SDR, but using the SoapySDR
+vendor-neutral SDR support library instead, intended to support a wider range
+of devices than RTL-SDR.")
+ (license license:gpl2+))))
+
(define-public gnss-sdr
(package
(name "gnss-sdr")