summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-05-28 11:15:21 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-28 11:15:21 +0200
commit5e0b11fbe8e60f1ba690b7c579c44814ab1ef92f (patch)
tree855b6c7346ac6670a27ffff7ef48da8d77d00e65 /gnu/packages/radio.scm
parent4ad3f818c9e2d200bf5c9cf0cf986b1a185d9d5b (diff)
downloadguix-patches-5e0b11fbe8e60f1ba690b7c579c44814ab1ef92f.tar
guix-patches-5e0b11fbe8e60f1ba690b7c579c44814ab1ef92f.tar.gz
gnu: hackrf: Update to 2021.03.1.
* gnu/packages/radio.scm (hackrf): Update to 2021.03.1.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm87
1 files changed, 41 insertions, 46 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index c2886cd1ac..8f9e180723 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -799,61 +799,56 @@ for correctness.")
(license license:gpl3+)))
(define-public hackrf
- ;; Using a git commit because there have been many many commits
- ;; since the relase two years ago, but no sign of a promised
- ;; release for many months now.
- (let ((commit "43e6f99fe8543094d18ff3a6550ed2066c398862")
- (revision "0"))
- (package
- (name "hackrf")
- (version (git-version "2018.01.1" revision commit))
- (source
- (origin
+ (package
+ (name "hackrf")
+ (version "2021.03.1")
+ (source
+ (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/mossmann/hackrf")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0avnv693xi0zsnrvkbfn0ln1r3s1iyj0bz7sc3gxay909av0pvbc"))))
- (build-system cmake-build-system)
- (arguments
- '(#:configure-flags
- (list "-DUDEV_RULES_GROUP=dialout"
- (string-append "-DUDEV_RULES_PATH="
- (assoc-ref %outputs "out")
- "/lib/udev/rules.d"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'enter-source-directory
- (lambda _
- (chdir "host")
- #t))
- (add-after 'install 'delete-static-library
- (lambda* (#:key outputs #:allow-other-keys)
- (delete-file (string-append (assoc-ref outputs "out")
- "/lib/libhackrf.a"))
- #t))
- (add-before 'install-license-files 'leave-source-directory
- (lambda _
- (chdir "..")
- #t)))
- #:tests? #f)) ; no test suite
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("fftw" ,fftw)
- ("fftwf" ,fftwf)
- ("libusb" ,libusb)))
- (home-page "https://greatscottgadgets.com/hackrf/")
- (synopsis "User-space library and utilities for HackRF SDR")
- (description
- "Command line utilities and a C library for controlling the HackRF
+ (base32 "12fkgimjy5ia291c1rn4y59pn9r5wdvz5x9z5xc8zr1xr96iyhfs"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ (list "-DUDEV_RULES_GROUP=dialout"
+ (string-append "-DUDEV_RULES_PATH="
+ (assoc-ref %outputs "out")
+ "/lib/udev/rules.d"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'enter-source-directory
+ (lambda _
+ (chdir "host")
+ #t))
+ (add-after 'install 'delete-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file (string-append (assoc-ref outputs "out")
+ "/lib/libhackrf.a"))
+ #t))
+ (add-before 'install-license-files 'leave-source-directory
+ (lambda _
+ (chdir "..")
+ #t)))
+ #:tests? #f)) ; no test suite
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("fftw" ,fftw)
+ ("fftwf" ,fftwf)
+ ("libusb" ,libusb)))
+ (home-page "https://greatscottgadgets.com/hackrf/")
+ (synopsis "User-space library and utilities for HackRF SDR")
+ (description
+ "Command line utilities and a C library for controlling the HackRF
Software Defined Radio (SDR) over USB. Installing this package installs the
userspace hackrf utilities and C library. To install the hackrf udev rules,
you must extend 'udev-service-type' with this package. E.g.:
@code{(udev-rules-service 'hackrf hackrf #:groups '(\"dialout\"))}.")
- (license license:gpl2))))
+ (license license:gpl2)))
(define-public hamlib
(package