summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-04-10 11:46:12 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-04-10 11:46:12 +0200
commit5b49626bc2ec39316dd4a0ff2aff5b9158294fa0 (patch)
tree738a7cf0fd33aa5d4e5e0517fa1bfe11fc0cf671 /gnu/packages/radio.scm
parent59134f1e02dbde6d82e6204b51ca49347b8037d9 (diff)
downloadguix-patches-5b49626bc2ec39316dd4a0ff2aff5b9158294fa0.tar
guix-patches-5b49626bc2ec39316dd4a0ff2aff5b9158294fa0.tar.gz
gnu: Add airspyhf.
* gnu/packages/radio.scm (airspyhf): New variable.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index afe93081b3..4c1ecbfe66 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -172,6 +172,46 @@ To install the rtl-sdr udev rules, you must extend 'udev-service-type' with
this package. E.g.: @code{(udev-rules-service 'rtl-sdr rtl-sdr)}")
(license license:gpl2+)))
+(define-public airspyhf
+ (package
+ (name "airspyhf")
+ (version "1.6.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/airspy/airspyhf")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n699i5a9fzzhf80fcjlqq6p2a013rzlwmwv4nmwfafy6c8cr924"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libusb" ,libusb)))
+ (arguments
+ '(#:configure-flags '("-DINSTALL_UDEV_RULES=ON")
+ #:tests? #f ; No tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "tools/CMakeLists.txt"
+ (("DESTINATION \"/etc/udev/")
+ (string-append "DESTINATION \""
+ (assoc-ref outputs "out")
+ "/lib/udev/"))))))))
+ (home-page "https://github.com/airspy/airspyhf")
+ (synopsis "Software defined radio driver for Airspy HF+")
+ (description
+ "This package provides the driver and utilities for controlling the Airspy
+HF+ Software Defined Radio (SDR) over USB.
+
+To install the airspyhf udev rules, you must extend @code{udev-service-type}
+with this package. E.g.: @code{(udev-rules-service 'airspyhf airspyhf)}")
+ (license license:bsd-3)))
+
(define-public chirp
(package
(name "chirp")