summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-25 12:07:04 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-25 12:07:04 +0200
commit45e132ee7a54f4b94e3b63d6edcbcfd1c9723193 (patch)
tree66fdd51c55c81e84bfe58ceab9926f233262328b /gnu/packages/radio.scm
parent80aeefd517b1355ccd1accb09f0d998d84436beb (diff)
downloadguix-patches-45e132ee7a54f4b94e3b63d6edcbcfd1c9723193.tar
guix-patches-45e132ee7a54f4b94e3b63d6edcbcfd1c9723193.tar.gz
gnu: Add rx-tools.
* gnu/packages/radio.scm (rx-tools): New variable.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 3d9a76a8b2..7707fcf004 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -2340,6 +2340,37 @@ this package. E.g.: @code{(udev-rules-service 'rfcat rfcat)}")
(license (list license:bsd-3
license:gpl2)))))
+(define-public rx-tools
+ ;; No tagged release since 2016, use commit instead.
+ (let ((commit "811b21c4c8a592515279bd19f7460c6e4ff0551c")
+ (revision "1"))
+ (package
+ (name "rx-tools")
+ (version (git-version "1.0.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rxseger/rx_tools")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qr8q00cv6q0ikjrph0qh07mlbvgk4yimccpkn3ir8ib5ma0r9sr"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("soapysdr" ,soapysdr)))
+ (arguments
+ `(#:tests? #f)) ; No test suite.
+ (home-page "https://github.com/rxseger/rx_tools")
+ (synopsis "Command line programs for receiving data from SDRs")
+ (description
+ "This package provides the @code{rx_fm}, @code{rx_power} and
+@code{rx_sdr} tools for receiving data from SDRs, based on @code{rtl_fm},
+@code{rtl_power} and @code{rtl_sdr} from RTL-SDR, but using the SoapySDR
+vendor-neutral SDR support library instead, intended to support a wider range
+of devices than RTL-SDR.")
+ (license license:gpl2+))))
+
(define-public gnss-sdr
(package
(name "gnss-sdr")