summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-07-13 16:15:38 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-07-13 16:21:02 +0200
commit4196087f3d6fc254db5b4c47658e5679c835516f (patch)
treea8d3ddf5325f83474f461e945666c7866212b181 /gnu/packages/radio.scm
parent5fa078ccfd62fc4ea80ac16dfa365e66afabe9a6 (diff)
downloadguix-patches-4196087f3d6fc254db5b4c47658e5679c835516f.tar
guix-patches-4196087f3d6fc254db5b4c47658e5679c835516f.tar.gz
gnu: Add gr-satellites.
* gnu/packages/radio.scm (gr-satellites): New variable.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 5b1d7c5683..7ee0851311 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -75,6 +75,7 @@
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-science)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
@@ -778,6 +779,59 @@ to the fix block above.
(license license:gpl3+))))
(deprecated-package "gnuradio-iqbalance" gr-iqbal)
+(define-public gr-satellites
+ (package
+ (name "gr-satellites")
+ (version "4.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/daniestevez/gr-satellites")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01p9cnwjxas3pkqr9m5fnrgm45cji0sfdqqa51hzy7izx9vgzaf8"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("pybind11" ,pybind11)
+ ("python-six" ,python-six)))
+ (inputs
+ `(("boost" ,boost)
+ ("gmp" ,gmp)
+ ("gnuradio" ,gnuradio)
+ ("log4cpp" ,log4cpp)
+ ("python" ,python)
+ ("python-construct" ,python-construct)
+ ("python-numpy" ,python-numpy)
+ ("python-pyaml" ,python-pyaml)
+ ("python-pyzmq" ,python-pyzmq)
+ ("python-requests" ,python-requests)
+ ("volk" ,volk)))
+ (arguments
+ `(#:modules ((guix build cmake-build-system)
+ ((guix build python-build-system) #:prefix python:)
+ (guix build utils))
+ #:imported-modules (,@%cmake-build-system-modules
+ (guix build python-build-system))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-test-environment
+ (lambda _
+ (setenv "HOME" "/tmp")))
+ (add-after 'install 'wrap-python
+ (assoc-ref python:%standard-phases 'wrap)))))
+ (synopsis "GNU Radio decoders for several Amateur satellites")
+ (description
+ "@code{gr-satellites} is a GNU Radio out-of-tree module encompassing
+a collection of telemetry decoders that supports many different Amateur
+satellites.")
+ (home-page "https://github.com/daniestevez/gr-satellites")
+ (license (list license:asl2.0
+ license:gpl3+
+ license:lgpl2.1))))
+
(define-public gqrx
(package
(name "gqrx")