summaryrefslogtreecommitdiff
path: root/gnu/packages/racket.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2021-09-06 00:59:02 -0400
committerLudovic Courtès <ludo@gnu.org>2021-09-10 17:30:55 +0200
commitfd22921490f40044d58be8ddc3b38b8be12188a6 (patch)
tree83f4851b3c604ad8d2f47c19ff3a497b67ad6e6d /gnu/packages/racket.scm
parent60b42bec8413aa9844e625fb1903257f1bc1e55c (diff)
downloadguix-patches-fd22921490f40044d58be8ddc3b38b8be12188a6.tar
guix-patches-fd22921490f40044d58be8ddc3b38b8be12188a6.tar.gz
gnu: racket: fix `raco exe` with non-minimal Racket
This commit backports an upstream repair for a bug exposed by Guix's change in Racket 8.2 to make the `racket` package a layered/tethered installation that chains to the `racket-minimal` package. When using a layered/tethered installation, the `setup/variant` library would fail to recognize the default Racet variant (CS, 3M, or CGC), leading to confusing failures from `raco exe`, `create-embedding-executable`, and other clients. For further details, see <https://issues.guix.gnu.org/50118> and <https://github.com/racket/racket/issues/3969>. * gnu/packages/patches/racket-minimal-backport-1629887.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/racket.scm (racket-minimal)[source]: Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/racket.scm')
-rw-r--r--gnu/packages/racket.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index 8349c5032c..5b3e941e61 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -138,7 +138,9 @@
(sha256
"061bhiyjlvazph0dj9i3i3x2q5z53rp8h5cjwg3frjimkr45lncn")
(file-name (git-file-name name version))
- (patches (search-patches "racket-minimal-sh-via-rktio.patch"))
+ (patches (search-patches "racket-minimal-sh-via-rktio.patch"
+ ;; Remove the following in version 8.3:
+ "racket-minimal-backport-1629887.patch"))
(modules '((guix build utils)))
(snippet
(with-imported-modules '((guix build utils))