summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-28 17:44:36 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-28 18:08:30 +0200
commitf3152cf3021892ba7e2f3d837207eb1ee64bfdb6 (patch)
tree851a4e213db561fb92045a26ba521cecbd09c381 /gnu/packages/qt.scm
parent4c9d8ff14212c7266b80ccd498f96f92eb1a08a0 (diff)
downloadguix-patches-f3152cf3021892ba7e2f3d837207eb1ee64bfdb6.tar
guix-patches-f3152cf3021892ba7e2f3d837207eb1ee64bfdb6.tar.gz
gnu: qtwebkit: Fix build.
* gnu/packages/qt.scm (qtwebkit)[arguments]: Replace the standard build phase with a custom one that increases the maximum number of open file descriptors.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 5c0576c880..88126d2685 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2677,7 +2677,19 @@ different kinds of sliders, and much more.")
;; libraries and test executables in a
;; reasonable amount of memory.
"-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
- "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
+ "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ ;; This is a workaround for the build failing with the error:
+ ;; ld: error adding symbols: Malformed archive
+ ;; Increasing the maximum number of open file descriptors
+ ;; makes the build succeed.
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (let ((cmd (format #f
+ "ulimit -n 4096; make ~{~a~^ ~}"
+ make-flags)))
+ (invoke "sh" "-c" cmd)))))))
(home-page "https://www.webkit.org")
(synopsis "Web browser engine and classes to render and interact with web
content")