summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-02-21 21:13:47 -0800
committerMarius Bakke <mbakke@fastmail.com>2020-02-24 17:10:22 +0100
commite2546bb472b6285a8856cacf686c5e0ce9bb62c5 (patch)
treed355ada035dbdcb6035fdfd52423639522487e0d /gnu/packages/qt.scm
parentdbf15d86e980c399f357f081d7753814ee1b9640 (diff)
downloadguix-patches-e2546bb472b6285a8856cacf686c5e0ce9bb62c5.tar
guix-patches-e2546bb472b6285a8856cacf686c5e0ce9bb62c5.tar.gz
gnu: qtbase: Add variant that fixes file name handling in CMake macros.
* gnu/packages/patches/qtbase-QTBUG-81715.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/qt.scm (qtbase-patched): New public variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 466c6ba358..7aa9d0f0f9 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -598,6 +598,19 @@ developers using C++ or QML, a CSS & JavaScript like language.")
developers using C++ or QML, a CSS & JavaScript like language.")
(license (list license:lgpl2.1 license:lgpl3))))
+;; This variant fixes a problem with the CMake macros shipped by qtbase. See
+;; discussion at <https://lists.gnu.org/archive/html/guix-devel/2020-02/msg00308.html>.
+(define-public qtbase-patched
+ (let ((src (package-source qtbase)))
+ (hidden-package
+ (package
+ (inherit qtbase)
+ (source
+ (origin
+ (inherit src)
+ (patches
+ (append (search-patches "qtbase-QTBUG-81715.patch")
+ (origin-patches src)))))))))
;; qt used to refer to the monolithic Qt 5.x package
(define-deprecated qt qtbase)