summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-24 23:59:30 +0200
committerMarius Bakke <marius@gnu.org>2020-07-24 23:59:30 +0200
commitc23737d6e4ce670477e45c1ce2a0d125ae459c47 (patch)
treeb28f799bfce9b3ecbc8709a9b6781401ea8f348a /gnu/packages/qt.scm
parent7f9d8a62ca69ea587cbf07e85510b1fa767ee0a0 (diff)
downloadguix-patches-c23737d6e4ce670477e45c1ce2a0d125ae459c47.tar
guix-patches-c23737d6e4ce670477e45c1ce2a0d125ae459c47.tar.gz
gnu: qtbase: Incorporate bugfix variants.
* gnu/packages/qt.scm (qtbase/next, qtbase-for-krita): Remove variables. (qtbase)[source](patches): Add "qtbase-absolute-runpath.patch" and "qtbase-fix-krita-deadlock.patch". (python-pyside-2-tools)[inputs]: Change from QTBASE/NEXT to QTBASE. * gnu/packages/kde.scm (krita)[inputs]: Change from QTBASE-FOR-KRITA to QTBASE.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm28
1 files changed, 4 insertions, 24 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 1cbf7991ab..949d56d87b 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -342,7 +342,6 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(define-public qtbase
(package
(name "qtbase")
- ;; TODO Remove ((gnu packages kde) qtbase-for-krita) when upgrading qtbase.
(version "5.14.2")
(source (origin
(method url-fetch)
@@ -355,7 +354,9 @@ developers using C++ or QML, a CSS & JavaScript like language.")
"12mjsahlma9rw3vz9a6b5h2s6ylg8b34hxc2vnlna5ll429fgfa8"))
;; Use TZDIR to avoid depending on package "tzdata".
(patches (search-patches "qtbase-use-TZDIR.patch"
- "qtbase-moc-ignore-gcc-macro.patch"))
+ "qtbase-moc-ignore-gcc-macro.patch"
+ "qtbase-absolute-runpath.patch"
+ "qtbase-fix-krita-deadlock.patch"))
(modules '((guix build utils)))
(snippet
;; corelib uses bundled harfbuzz, md4, md5, sha3
@@ -597,27 +598,6 @@ developers using C++ or QML, a CSS & JavaScript like language.")
;; qt used to refer to the monolithic Qt 5.x package
(define-deprecated qt qtbase)
-;; This variable is required by 'python-pyside-2-tools', which copies some
-;; qtbase executables that fail to run because RUNPATH refers to the
-;; wrong $ORIGIN. TODO: Merge with qtbase in the next rebuild cycle.
-(define qtbase/next
- (package
- (inherit qtbase)
- (source
- (origin
- (inherit (package-source qtbase))
- (patches (append (origin-patches (package-source qtbase))
- (search-patches "qtbase-absolute-runpath.patch")))))))
-
-(define-public qtbase-for-krita
- (hidden-package
- (package
- (inherit qtbase)
- (source (origin
- (inherit (package-source qtbase))
- (patches (append (origin-patches (package-source qtbase))
- (search-patches "qtbase-fix-krita-deadlock.patch"))))))))
-
(define-public qtsvg
(package (inherit qtbase)
(name "qtsvg")
@@ -2721,7 +2701,7 @@ generate Python bindings for your C or C++ code.")
(inputs
`(("python-pyside-2" ,python-pyside-2)
("python-shiboken-2" ,python-shiboken-2)
- ("qtbase" ,qtbase/next)))
+ ("qtbase" ,qtbase)))
(native-inputs
`(("python" ,python-wrapper)))
(arguments