summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-18 15:48:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-08-29 14:44:21 +0200
commitaf9afb0bc40ac74b75e820fbd6a6222c82febc9f (patch)
tree40e437d51ed3fad20cd53d2eeabfb1fa7d00bc4e /gnu/packages/qt.scm
parent2271a1dcdbaa5b54967aa2f31e96db2f90528376 (diff)
downloadguix-patches-af9afb0bc40ac74b75e820fbd6a6222c82febc9f.tar
guix-patches-af9afb0bc40ac74b75e820fbd6a6222c82febc9f.tar.gz
gnu: QtWebKit: Increase build timeout.
* gnu/packages/qt.scm (qtwebkit)[properties]: New field.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index daef46faf6..52eb46cce0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2209,6 +2209,9 @@ content")
(description "QtWebKit provides a Web browser engine that makes it easy to
embed content from the World Wide Web into your Qt application. At the same
time Web content can be enhanced with native controls.")
+ ;; Building QtWebKit takes around 13 hours on an AArch64 machine. Give some
+ ;; room for slower or busy hardware.
+ (properties '((timeout . 64800))) ;18 hours
(license license:lgpl2.1+)))
(define-public dotherside